CentOS7 to Windows10, Error is 110

Forum / NoMachine for Windows / CentOS7 to Windows10, Error is 110

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #16587

    Use NoMachine on CentOS7 to Windows10, Error is 110: Connection timed out’. Reverse connection is OK.

    NoMachine on CentOS7 and Windows10 is version 5.1.9.

    Log file “session” and “settings” on attachments.

    Log file “connection” is 0B.


    The logs were perhaps too big and so didn’t attach. Can you submit them directly to forum[at]nomachine[dot]com? Thanks!


    Thanks for your time!

    Submit to forum[at]nomachine[dot]com
    Email title: 『#16587[attachments] Title: ‘CentOS7 to Windows10, Error is 110’』


    Session content:

    Info: Starting NoMachine version 5.1.9.
    Info: Loading settings from ‘/job/HOME/zhaobx/.nx/config/player.cfg’.
    Info: Loaded translation files for ‘English’.
    12241 12241 16:19:56 612.174 Main: Creating the client session.
    12241 12241 16:19:56 612.231 ClientSession: Initializing session at 0x16f6840.
    12241 12241 16:19:56 722.745 ClientSession: Initialized session at 0x16f6840.
    Info: Slave server running with pid 12259.
    12241 12241 16:19:56 724.501 Main: Entering the GUI event loop.
    Info: Listening to slave connections on port 34239.
    12241 12241 16:20:06 398.664 ClientSession: Starting session at 0x16f6840.
    12241 12241 16:20:06 399.709 ClientSession: Going to start session ‘/job/HOME/zhaobx/文档/NoMachine/Connection to’.
    12241 12241 16:20:06 418.050 Connection: Initializing connection at 0x1b7e710.
    12241 12241 16:20:06 418.127 Connection: Initialized connection at 0x1b7e710.
    12241 12241 16:20:06 418.147 Connection: Starting connection at 0x1b7e710.
    12241 12241 16:20:06 418.161 ClientDaemonConnector: Starting a new connection to host ‘’ on port ‘4000’.
    12241 12241 16:20:06 419.394 Connection: Started connection at 0x1b7e710.
    12241 12241 16:20:06 428.310 ClientSession: Started session at 0x16f6840.
    12241 12241 16:20:36 419.279 Connection: Connection at 0x1b7e710 failed.
    12241 12241 16:20:36 419.581 ClientSession: Runnable at 0x1b7e710 caused the session at 0x16f6840 to fail.
    12241 12241 16:20:36 419.596 ClientSession: Failing reason is ‘Could not connect to the server.

    Error is 110: 连接超时’.
    12241 12241 16:20:36 424.052 ClientSession: Stopping session at 0x16f6840.
    Info: Slave server running with pid 12640.
    12241 12241 16:20:36 437.965 Connection: Stopping connection at 0x1b7e710.
    12241 12241 16:20:36 437.997 ClientDaemonConnector: Stopping the current connection.
    12241 12241 16:20:36 438.015 Connection: Stopped connection at 0x1b7e710.
    Info: Listening to slave connections on port 55397.
    12241 12241 16:20:36 448.232 ClientSession: Stopped session at 0x16f6840.
    kdeinit4: Shutting down running client.
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    KDE Daemon (kded) already running.
    kbuildsycoca4 running…
    kbuildsycoca4(12797) VFolderMenu::loadDoc: Parse error in  “/amount/shotgun_home/zhaobx/.config/menus/applications-merged/xdg-desktop-menu-dummy.menu” , line  1 , col  1 :  “unexpected end of file”
    12241 12784 16:21:01 222.051 FileBrowser: File ‘/home’ was selected.

    settings content:



    First check your firewall settings and allow connections via NX to port 4000. We would also need the server-side logs. Please check the instructions here: https://www.nomachine.com/DT07M00098. The logs you sent in earlier were of the client side.


    Firewall is closed.

    NoMachine on CentOS7 and Windowns10, update to version: 6.0.62.


    Sent email to forum[at]nomachine[dot]com


    The logs you submitted are from the server component of the connecting Linux client. What we need is the server logs from the Windows host that you are connecting to. Enable debug there, connect from your Linux client to reproduce the behaviour, and then gather up the logs, again following the instructions from the article in the KB).


    Sorry for the inconvenience owing to my previous mistakes. I have sent the mail.


    We found some unusual behaviour in logs you sent.

    Can you tell us more about your Windows 10 edition and language variant?

    We will try to reproduce a problem in our lab.


    Enterprise Version 1607(OS build 14393.0)
    Most people here are using English version, a few of them are using other version.  ^_^


    Can you enable logs by edit the installationDirectory/NoMachine/etc/server.cfg.
    Uncomment and set the following:
    SessionLogLevel 7
    then restart nxserver with command:
    installationDirectory/NoMachine/bin/nxserver –restart
    and send us again logs? Logs of daemon process are missing and restart is requested to enable them.


    Please test.


    Mail has been sent. What else can I do?


    Logs are unclear, something is blocking sockets. We cannot reproduce issue. Maybe the problem is with anti-virus / firewall? Which one are you using?



    Thank you very much, I will try other ways to do this.  ^_^

Viewing 15 posts - 1 through 15 (of 15 total)

This topic was marked as solved, you can't post.