CMD key not working in Mac Client + Mac Host

Forum / NoMachine for Mac / CMD key not working in Mac Client + Mac Host


Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #8174

    Hi all — I’ve search high and low for a solution to this but am stuck.

    Essentially, when I connect from a Mac client to a Mac host, the “command” key is never picked up *even* if I change the modifier keys on the host e.g. ctrl –> cmd

    This means (IMHO) vital keyboard shortcuts do not work such as cmd+tab and cmd+space

    I have full screen mode turned on, cursor and keyboard grabbing turned on, and still I can’t get the command key to be picked up.

    I have even installed to visually confirm that the OS isn’t seeing the command key ever pressed — every other key seems to work

    It’s worth noting I tried this from a Windows client and don’t experience the same issue.

    I’m running the latest versions of all clients and hosts.

    Can anyone else confirm this behavior isn’t isolated to my setup?


    Hello captaink.

    I reproduce a similar issue. By the way, I can see that server host gets the Cmd key: I keep the on screen keyboard open on the server host, and if I press Cmd on client, I see that Cmd key on the on screen keyboard is highlighted.

    The shortcuts Cmd+Tab and Cmd+Space don’t work, indeed.

    Could you clarify this point? Which description among the following two matches with issue you found:

    1. Cmd key event is not received at all by server host at
    2. Cmd key event is received, but shortcuts don’t work




    Yes, I can confirm now by using the on-screen keyboard that cmd is being received; however, the shortcuts remain unusable.

    When pressing cmd+tab, only the cmd key will appear pressed in the on-screen keyboard. Other keyboard combination appear to work that do not use the cmd key…

    Thank you for confirming the issue is reproduceable.

    Any next steps we can take?


    A Trouble Report was created about this issue:


    If you haven’t already done so, please update to the latest version. A fix was released in NoMachine 5.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.