Connect to existing custom session on Linux

Forum / NoMachine for Linux / Connect to existing custom session on Linux

  • This topic has 6 replies, 3 voices, and was last updated 6 years ago by Tor.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #17314
    johnsonatx
    Participant

    I’m trying to figure out how to configure a one-click solution (from Windows client) that will open NoMachine (on Linux) and log into a specific server and session.  I’ve gotten as far as modifying the .NXS file and being able to click it which will open NX to the specific machine but it won’t open the session.  I have a custom session running an LXDE GUI, which shows when I login.  I can double click it to open, but I’d like it to open automatically.

    Can someone help me understand which value in the .NXS file I need to modify.  I’ve spend the last few hours trying to figure it out myself with no luck.  I was following the documentation I found here
    https://www.nomachine.com/DT02M00075

    Thanks in advance for your help!

     

    #17329
    Tor
    Participant

    Hi. Would you like to share your NXS file, so we can check how it is configured and run a few tests? You can send it to forum[at]nomachine[dot]com. I’d suggest to delete the following fields for security reasons:

    <option key="Server host" value="" />
    <option key="User" value="" />
    <option key="Auth" value="EMPTY_PASSWORD" />
    #17340
    Britgirl
    Participant

    Hi, please send your nxs session file to

    …forum[at]nomachine[dot]com…

    It’s too long to paste into the topic page. Thanks!

    #17349
    johnsonatx
    Participant

    Appears it pasted full content of file to topic page but I’ve also emailed the file

    #17426
    johnsonatx
    Participant

    any update?

    #17447
    Britgirl
    Participant

    We received the requested information, and it’s in the queue. The past week has been hectic preparing for the release (today). Thanks for your patience 🙂

    #17452
    Tor
    Participant

    Hi. Your connection file includes all values needed to automatically connect to a running session, and I’ve confirmed it with some tests, so the problem must be somewhere else. Please check the following:

    • The routine looking for a session to reconnect checks also some user defined parameters, like the name of the connection. You may try to rename the connection to verify if a shorter or different name helps.
    • Automatic reconnection can be disabled in server configuration. If you can access the file server.cfg, verify that the key ConnectPolicy is including the value autoconnect=1. If you can’t access server configuration, verify the file ‘connection’ in client side logs and search for the text autoconnect yes.

    If nothing helps, please send to our mail address a set of client logs.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.