Connection refused message

Forum / NoMachine for Linux / Connection refused message

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #767


    I installed NoMachine for linux i686 (4.0.366_1) and confirmed that the server is running. (I am not sure if it is ok for me the see the version as 3.2.0 in the nxserver. dont know why that is happening. tried uninstalling nomachine and then installing back. still see the problem)

    $ nxserver –status
    NX> 100 NXSERVER – Version 3.2.0-74-SVN OS (GPL, using backend: not detected)
    NX> 110 NX Server is running
    NX> 999 Bye

    Now i am trying to connect from my Mac and i get an error saying that connection is refused. it says the error is 61. Anyone has any idea what is happening? Would really appreciate the help



    I would uninstall the freenx binary you’ve got on that machine before installing NoMachine. Freenx issues need to be dealt with by the freenx project.


    Hi Juddbs,

    I tried to uninstall freenx binary and then installed NoMachine. Now i see the correct version of the nxserver running.

    $ ./nxserver –version
    NoMachine – Version 4.0.366

    $ ./nxserver –status
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxd.

    Now when i try to connect from my mac, i see the following error:

    No available session found error. The server was unable to make the local display available or access to the local display is disabled.

    Do you know why that would happen? I have installed the free edition, not the enterprise one.


Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.