Connection reset by peer

Forum / NoMachine for Windows / Connection reset by peer

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #28247

    I can connect my desk computer to my remote laptop and see its desktop but after a few seconds the page is replaced
    with a NoMachine page displaying the message “Attempting to reconnect Error was: Connection Reset by Peer”.

    It was working in early June but not now.

    I am running Win 10 Prof(Build 1909) on laptop, Win 10 Home on desktop(build 1809).
    I have tried reinstalling NoMachine (6.11.2_1 free version) on both computers and rebooting
    I have also tried an earlier version of NoMachine (6.8.1_1 free version) on both.

    All give the same message!

    Please help


    It’s difficult to say what is happening and why without seeing the logs. We would need them from both client and server sides.Please see the instructions here: Submit both sets to forum[at]nomachine[dot]com making sure you use the title of this topic as the subject of your email. Thanks!


    I have retrieved the server log but am having trouble getting the client’s log. I don’t understand the instruction:

    “Collecting client side logs manually requires to make the following operations on the user’s computer from which the connection is started:”

    Is the “user’s computer” the client or the server? I assumed it was the server and looked on the client for the /.nx directory but couldn’t find it.

    – Patrick


    The client-side logs refer to the machine that you are connecting from, the device where you initiate the NoMachine connection. The server-side logs refer to the computer or host you are connecting to.

    Please send them to forum[at]nomachine[dot]com making sure to use the title of the topic as the subject of your email. Thanks 🙂


    I have attached what I hope are the correct folders.

    I could not find the nxtrace.log file but included the client .nx folder anyway.

    –  Patrick


    Apologies for the late reply. The logs don’t really show much other than possible UDP issues. Can you disable UDP on the player side? To do that select the connection icon, right click and select Edit, click Advanced and make sure the ‘Use UDP’ box is not flagged.


    The “Use UDP” box was flagged.

    I unflagged it and was able to connect and did not get the message “Connection reset by peer”.

    Everything is working the way it used to.

    Thank you Britgirl.  You can close this case.

    – Patrick A.




    Hi PatrickA,

    We receive your logs and reopened the topic.

    The logs show that NoMachine fails to connect to the existing display but they are not complete. Could you collect new logs using the command: /etc/NX/nxserver –debug –collect? Thanks!



    I have the same problem when trying to connect to an XP server with a Win 10 client. The server has a legacy bundled software which I want to be able to use from the new workstations.

    Once the client passes the login step, insted of seeing the server’s desktop, it got dropped with Connection reset by peer error message. I attached the server nx folder. The log was made after a fresh installation. The server was up and running without errors. I tried to connect twice, that is in the logs. I was not waited the 5 attempts at client side but closed the window after first error in both times.

    Seeing the logs it seems there is some problem of reaching the node files. Log error complains file does not exist but it does. The issue might get caused that the server PC uses CP1250 codepage (or CP1252) and the username contains both space and accents.

    Looking forward to some help with the issue.

    Thanks in advance,



    Hello, would you collect the whole folder %ProgramData%\NoMachine\var\log ?


    Sure, I will do it once I am back to office. I had a medical treatment and I am uncertain whether I will go there within this or the upcoming 1-2 weeks. Please be patient.




    Today I started with two attempts to connect from the Win10 machine to the XP one.

    Both times I got _Connection reset by peer_ errors.



    Win10 – NoMachine 7.6.2

    XP – NoMachine 7.7.4


    For the third attempt I updated the Win10 machine to version 7.7.4, 64 bit.

    Same error.


    Between attempt 2 and 3 I successfully connected from the XP machine to the Win10 one

    Thus the problem persist to one direction only.


    I attached a pile of logs and settings files and a screen recording of the problem.


    Thanks for this great application!


    I would be very thankful if this problem would get solved.



    Ádám Szieberth


    File size too big to be uploaded to the Forum:


    NXSERVER WARNING! Cannot open file ‘C:\Documents and Settings\All Users\\NoMachine\\var\\db\\update’. Error is 13, EACCES, Permission denied.

    Please check the access rights to that folder.

    We see also error messages about a module that is supposed to be registered to the system and loaded on reboot after installation.

    It is possible that module wasn’t updated correctly.

    Please let us know the output of command nxservice64.exe --status nxlsa and nxservice32.exe --status nxlsa (You have to run cmd as Administrator and change directory to %PROGRAMFILES(x86)%\NoMachine\bin in order to run those nxservice commands).

    Did you try to remove completely the old installation and reboot before installing the latest NoMachine package?



Viewing 13 posts - 1 through 13 (of 13 total)

This topic was marked as solved, you can't post.