Connection timeout when connecting from Windows 10 Hyper-V Host to Ubuntu 20 VM

Forum / NoMachine for Linux / Connection timeout when connecting from Windows 10 Hyper-V Host to Ubuntu 20 VM

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #34532

    Strangest thing, which only started a few days ago. Could be a coincident, but the configuration was stable and performing correctly until I updated to 7.4.3. Could be coincidence.

    My problem: Cannot make connections from the hyper-v host computer to the hosted Ubuntu VM. Like I said above, it worked for a few months, up until about two’ish weeks ago.

    Neither the host machine nor the client computer are misconfigured. I know this because 1) connections from the host computer to non-hosted computers succeed and 2)  connections from computers other than the host to the hosted Ubuntu VM succeed.

    Yesterday, connections from the host to the hosted machine succeeded, following a couple of reboots of the host and VM. But, this morning, we are back to NXPlayer timeouts. Oddly, the player opens and the screen resizes, as if it’s building the connection, but then times-out.

    The only thing that fails is a connection between the host and the hosted NXServer.

    I’ve checked to ensure there isn’t a VLAN issue. VLANS aren’t configured.

    Please see attached logs. Any insight




    Could you forward those logs that failed to attach to forum[at]nomachine[dot]com?


    From the logs everything in NoMachine appears to be working fine. If the problem in connecting was with NoMachine, you would in theory be getting time-outs every time, not sporadically.  It could be a networking issue,  between the host and the guest?


    Hey Britgirl,

    Thanks for looking into the issue.

    It’s not a sporadic issue. It’s consistently broken.

    I’ve installed a second VM (Ubuntu) yesterday. Installed NoMachine. It worked fine yesterday. This morning, it’s now broken and behaving just like the first VM. Connections timeout.

    Something is amiss.

    Any other troubleshooting steps that you could recommend?



    Hi HammyMarc,

    Sorry for the delay.

    Do you know if all the IPs you’re using in your configuration are static? Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.