Connection to NX is slow

Forum / NoMachine for Windows / Connection to NX is slow

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #6981


    Running NX client 4.4.12 on Windows to connect to a Fedora 21 (v4) machine on my home network. I expected when I set this up to be blazingly fast with no noticeable different from actually working on the machine but I couldn’t be further from the truth. Not only there’s a noticeable difference where sometimes colours are off but if there’s a fast moving image or window the screen becomes blurry before refocusing properly. The blurring effect followed by refocusing makes my eyes bleed after a few hours.

    What’s the best way to understand if there’s a problem with the connection to the server or if there’s something I need to configure properly to improve the connection?



    Paulo Matos


    Hi pmatos,

    the blurring/refocusing effect you see is due to the progressive encoding technique used to increase the responsiveness. It can be disabled by checking the “Disable multi-pass display encoding” checkbox in the ‘Display settings’ tab from the menu panel. In the same panel you can tweak the Quality slider to find the better compromise between quality and performance.

    The colors shift is due to the colorspace conversion required by the encoder. Find here the Feature Request addressing this issue:

    Slowness depends certainly on the network bandwidth. Enabling the H.264 encoder would be a way to lower the used bandwidth. Here you can find the relevant info:

    Finally, since you are connecting to a linux server, you may want to try the “lightweight” mode. That would help with bandwidth usage and would provide perfect quality for most graphics elements on screen. Here are the info on the lightweight mode:
    In order to enable the lightweight mode, you need one of the Terminal Server products. Evaluation packages can be downloaded from this page:


    Thanks, I will be giving those strategies a try and see if it helps.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.