Constant dialog pop-up to allow nxnode to control mac

Forum / NoMachine for Mac / Constant dialog pop-up to allow nxnode to control mac

  • This topic has 1 reply, 2 voices, and was last updated 4 years ago by Mth.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #27932

    Every time I log on I get a popup that says “nxnode” would like to control this computer using accessibility features. – with a button to open system preferences.

    The only problem is that this permission is already granted, yet it keeps think it is not.

    It sounds suspiciously like a bug.




    Thank you for reporting this. Indeed it is an abnormal behavior.
    At first glance it seems this is caused by some leftovers in the system from previous installation. We have changed recently how this accessibility is handled and most probably it is not perfect yet.

    Could you please provide more information that should help us understand what happened?

    1. What OSX version do you have on this machine?
    2. Is it a clean installation, or update. Even if it is not an update,
    Maybe you had some another NoMachine version installed previously and
    removed before installation? If yes, which version?
    3. Was there any updates to osx itself recently?

    The most likely workaround for this kind of issue would be to shutdown the NoMachine server:

    /etc/NX/nxserver --shutdown

    Then manually remove all accessibility rights (remove, not just disable):

    1. From Screen Recording tab any “NoMachine” entry.
    2. From Accessibility tab any “nxnode” and “NoMachine” entry.

    Please check if they are not duplicated, if they are, also remove them and let us know that this happened too.

    After removing it from the access rights, start up the server again:

    /etc/NX/nxserver --startup

    After this you should be asked again to grant NoMachine the access rights and this time they should be proper.

    Let us know if this helped the situation.


Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.