Correct password rejected on Win10 logon page

Forum / NoMachine for Windows / Correct password rejected on Win10 logon page

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #34252


    I am using NoMachine for Windows 7.6.2 (trial version) in order to establish a NX connection between a local PC (client, Win 10) and an Azure VM (server, Win 10 Pro)  – (port 4000 is open in/outbound for TCP, UDP on Win firewall, Azure VM network security group). I have reinstalled NoMachine several times on both machines as admin with the same result.

    Brief issue description:

    I am able to connect via NoMachine client

    + server IP:4000 of my Azure VM
    + primary domainname of Active directory\username + pw
    + alternatively only, username\pw

    to my Azure VM

    Then I see the login screen with the Win password field. After inserting the win user pw, it says, “the password is wrong”.
    However the pw is correct, the same credentials work fine with my MS RDP connection (port 3389).

    I have read several threads on the web about the following issue. It seems that I am not the only one facing the
    correct password rejection at logon. Unfortunately, there seems to be no solution published for Win10.

    Could somebody please guide me out of this? It’s totally unexpected, I do not know, where to find the logs or further hints.
    Maybe there is only a manual configuration change required for NoMachine on server or client side?

    Thanks a lot!


    I did not noticed any issue with using NoMachine with Azure.

    What I am thinking is that possibly you are not using correct login form when connecting to the domain user ( user@DOMAIN or DOMAIN\user ).

    Additionally can you verify typed password on Windows login screen by using reveal button.



    thanks for the hint with the password reveal button, which took me one step further.

    By default this button is disabled in Win10 Pro, thus I had to edit the group policy.

    As a result I noticed that the keyboard mapping of the logon screen is different than after the logon (Azure VM German).
    Thus the plain password entry works now, even without domain name.
    I was able to enter it correctly by means of the pw reveal button.

    Do you have a clue where this different keyboard mapping of the logon screen is defined? (Win10 server? NoMachine client?) I did not expect a different keyboard language at logon. I always use German.
    Is it possible to skip this Win10 logon screen at the connection? (like with MS RDP connector)
    My credentials are already known via the connection definition of my NoMachine client ? Why entering things twice?

    Many thanks!



    I think the Windows login screen defaults to English layout. You could copy your user settings to the login screen using the Windows control panel (see picture).

    NoMachine always let user specify the proper account/credential to pass the Winlogon stage, without automatic forwarding of password strings.



    thank you for your valuable hint (screenshot above) it worked excellently.
    Now the logon screen is with German keyboard and NoMachine connection works with password as on the German client.
    The last remaining miracle to me is, why is MS RDP able to login immediately to the server desktop, whereas NoMachine connection requires entering the pw twice?

    Could I skip that step in Win10Pro or NoMachine?

    Thanks a lot


    why is MS RDP able to login immediately to the server desktop, whereas NoMachine connection requires entering the pw twice?

    That would be a new feature. At the present moment it isn’t possible to do it.


    NoMachine on Windows does connect to the physical screen thus requires entering login information on Windows login screen. I noticed that there is dismissed out of scope FR that was suppose to solve that problem



    Now the behaviour of my NoMachine connection is fully understandable.
    Summing up, the second input of the user pw on Win 10 Pro logon screen is required and works as designed by NoMachine.

    Many thanks for your helpful contributions,
    please close the issue!

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.