Crouton XFCE on Chromebook

Forum / NoMachine for Linux / Crouton XFCE on Chromebook


Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #25147

    I am running Crouton xfce on Chromebook.  I installed NoMachine in xfce but it cannot function.  If I type

    sudo /etc/NX/nxserver –upnpstatus

    I get blank for all three fields, though the server is enabled.

    My other devices can see it on the local network, but fails to connect.

    Perhaps the ports are not properly forwarded from the Chromebook to crouton.  Does anyone know how to work around this?


    Hello yinshslin,

    Logs might help to identify your issue, so please enable debug, than restart nxserver:
    nxserver --restart
    run also:
    nxserver --upnpstatus
    and collect logs.
    This article shows how to collect logs:


    Logs will no longer be necessary because it’s easily reproducible, but it is not NoMachine related.

    Please try that solution from crouton wiki:

    Install iptables:

    sudo apt-get install iptables

    When service would start – restart nxserver:

    sudo /usr/NX/bin/nxserver --restart

    Then you should be able to find your machine in the local network and connect there.


    Thank you for your comments.

    I tried installing iptables but it still did not work.  I attached the collected logs.

    For reference, I installed crouton with simply

    sudo sh ~/Downloads/crouton -t xfce

    I apologize if this is more of a crouton question than a NoMachine question.


    Probably iptables isn’t started after installation. You can logout from the xfce desktop and run and it again (startxfce4 or other command which you are using), then start nxserver sudo /usr/NX/bin/nxserver --start.


    Thank you for the suggestion, but I tried that before, and the result was the same.  Is there some non-NoMachine command that can let me check that iptables is indeed started?


    As you have in the link above: edit file rc.local (sudo vim /etc/rc.local) and add line:

    /sbin/iptables -P INPUT ACCEPT` to accept all inbound traffic

    or add to rc.local only NoMachine ports:

    /sbin/iptables -A INPUT -p udp -m multiport --dports 5353 -j ACCEPT
    /sbin/iptables -A INPUT -p tcp -m multiport --dports 4000 -j ACCEPT

    Thanks again for the comments, and sorry for my late reply.  This solution works!

    After changing rc.local, I initially could only connect via the local IP but had trouble when using the External IP.  But it was because I did not configure port forwarding properly on my Linksys WiFi router.  I followed the instructions here:

    (This is likely a very amateurish mistake, but I’m writing it just in case it is useful to anyone.)


    Still one caveat is that

    sudo /etc/NX/nxserver –upnpstatus

    still gives nothing.  Namely, the output is

    Local IP

    Gateway IP

    External IP

    But connecting with NoMachine works regardless.

    Thanks again for the help!


    Please try again to configure port forwarding. On Port Range Forwarding field set 4000 as Start and End Port. Then you need to choose router’s external IP and port 4000 to connect over internet.

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.