Ctrl/command shortcut keys for Windows

Forum / NoMachine for Windows / Ctrl/command shortcut keys for Windows

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #32547

    I have users with NoMachine on their Windows VM connecting to MacOS and are unable to use ctrl/command keyboard shortcut keys. I had them test using ctrl or Windows key (in place of command) with “Grab the keyboard input” both turned on and off. No shortcut keys seem to work such as copy/paste or in-program shortcuts like command + f  for search. \

    This appears to be a similar issue to this thread: https://forums.nomachine.com/topic/control-keys-not-working-for-copypaste but I have not found a way to enable activegrab in the Windows version of NoMachine. Is there a way to do this or is there another configuration I should try to fix this issue?



    Hi. Could you tell us what is the VM software, Windows and macOS versions? We’d like to run a test.
    The grab keyboard input on Windows is always “active” and we’re not aware of such difficulties in using keyboard shortcuts, so we need to understand what is interfering with the input catching. I’ve some questions:

    • Are all shortcuts ignored in the same way, or some of them pass through?
    • When a shortcut is ignored, does it trigger an action on Windows?

    Thank you for the response. We are using:

    VMware Horizon Client 5.4.1
    Windows 10 1809
    MacOS Big Sur

    We are able to copy/paste from/to the Mac and Windows VM. Occasionally I can get it to copy-paste on the Mac I am using through NoMachine by doing a “windows key” + c and “windows key” + v, with “Grab the keyboarding input” turned on but sometimes it does not respond to those shortcut keys and nothing happens. On a physical Windows machine running VMware it triggers a message saying that copied items have been save to clipboard. We also use zero clients that connect via VMware, and with that, I get no message when doing copy/paste.


    Sorry for updating this topic late, I thought one of us had followed up already. I checked just to make sure with the latest version of NoMachine. Even though your topic is more of a copy and paste issue, not a shortcuts-not-working issue which is what we originally thought, we don’t have any problems with shortcuts, nor with pasting between Mac and Windows VM.

    “I get no message when doing copy/paste.” – this is what VMware shows maybe? It’s not one of NoMachine’s own messages.

    If there is a problem with NoMachine not recognizing commands or clipboard not working properly, please state the steps for us to reproduce. Also confirm if this is a traditional NoMachine player session or a web session. Thanks.


    Hi Britgirl,

    Yes this is for all shortcut keys such as command + N, command + C, command + P. We found that if a user is on a Mac OS device, connects to a virtual machine with VMWare Horizon, then uses NoMachine on the VM to connect to another Mac OS  device the shortcut keys do not pass through. I do not know if this is too many pass-throughs but we don’t have this issue with connecting from a Windows-based machine. I have the latest NoMachine update installed on my user’s VM’s.


    Hi, at first I thought it might be nested sessions which was causing the problem, but it works for us with VirtualBox 🙂 From Mac to Win VM, start a new session and connect to Mac, (we had to enable grab keyboard in the NoMachine player before starting the session from the Win VM).

    With VMware it doesn’t work because basically VMware changes cmd to Ctrl , so it appears to be more of a problem with VMware? We tried with Fusion as well, cmd+N works, but cmd+C, cmd+V are transferred as ctrl+(C/V).

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.