Desktop Icons?

Forum / NoMachine for Linux / Desktop Icons?

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #6896

    I’ve looked everywhere, but can’t find any way to make a desktop icon for my remote machines.

    Is this possible?  (NX 4.4.12)


    Hi Quantum,

    Yes it is possible; NoMachine stores connection files in the following paths:

    Linux:  ~/Documents/NoMachine

    Windows: C:/Users/<user name>/Documents/NoMachine

    Mac: /Users/<user name>/Documents/NoMachine

    It should be enough to move a connection file from that directory to the Desktop and the client on it to start a session.


    Thanks, but nothing works.

    $ /home/bill/.nx/config/Hex.nxs
    bash: /home/bill/.nx/config/Hex.nxs: Permission denied
    $ /usr/NX/bin/nxclient /home/bill/.nx/config/Hex.nxs
    20161 20161 07:38:06 327.178 Socket: WARNING! Can’t create the IPv6 socket.
    20161 20161 07:38:06 327.360 Socket: WARNING! Error is 97 ‘Address family not supported by protocol’.

    $ /usr/NX/bin/nxclient.bin /home/bill/.nx/config/Hex.nxs
    /usr/NX/bin/nxclient.bin: error while loading shared libraries: cannot open shared object file: No such file or directory
    $ /usr/NX/bin/nxnode.bin /home/bill/.nx/config/Hex.nxs
    /usr/NX/bin/nxnode.bin: error while loading shared libraries: cannot open shared object file: No such file or directory



    Hi again Quantum,

    Let me first clarify that this file cannot by executed from bash or with nxclient/nxnode, like you have tried.

    What you have to do is: move session file (.nxs) from Documents/NoMachine (or from .nx/config if you have some session files created by NX 3.X) and then click on the icon.

    Let us know if you still encounter problems.


    I don’t have a Documents directory.  I do have ~/.nx/config/Hex.xns which I drag from file manager to the desktop itself (KDE), but it never appears on the desktop.  I try clicking on Hex.nxs in the file manager, but nothing happens.

    Normally what I do is Edit the Start menu and create a new object there.  I have to give the command which is run to start that object, but no commands work that I’ve tried so far.

    What is the actual mechanism of how this is supposed to start?  Isn’t an executable supposed to be associated with .nxs files?


    Hi Quantum,

    Please try this command: /usr/NX/bin/nxplayer —session session_file.nxs


    Thank you, that works.

    Another question:  Every morning when I start sessions on the various remote machines, it always says the remote host key has changed, and I have to approve the new key.  This should not happen, and could mask cases where the key has actually changed maliciously.  Why is this happening?


    Hi Quantum,

    The key should not change by itself over the night. It can change only after reinstallation of the software.

    Can you confirm that you didn’t reinstall it in the meantime ?

    Also, do you use the same access details (IP, port) as the ones used initially for the first connection to a host ?


    I agree it shouldn’t change.  I’ve only installed NX once on all my machines, yet every day it complains that the key has changed.  Same details, in fact I’ve created icons with the IP, port and other settings, which has never changed.

    Here’s how I use it, in case it makes a difference.  I run nxserver on the remote CentOS 7 machine. (installed with rpm)  The server starts with systemd.  In the config file I’ve changed each port it listens to, to reflect the IP of that host, for example listens to port 4014.  On the client machine, I set up a reverse SSH tunnel, which reaches out to the remote machine, takes, and brings it back to the client through the tunnel, so 4014 then shows up on the client at  On the client when I hit the icon, it goes to and the machine reaches into its bellybutton and gets 4014 from the remote machine as if the remote server is local.

    I’ve used reverse SSH tunnels for many years, to extend all kinds of services, and I can’t see why it would have an effect on the NX keys, but I thought I’d explain my method.  Also my method is the reason I wish there were a way to make nxserver listen only on, as I don’t want anything listening on outside interfaces for security reasons (in case the firewall is ever compromised).




    Hi Quantum.

    Normally host certificate or fingerprint get saved and the message only appears when there is a mismatch.
    If you’re using NX protocol, check if the following file exists and if it has correct access permissions:


    If you’re using SSH, check this file:


    If this doesn’t help, when you see the remote host key message pack the most recent logs directory ($HOME/.nx/R-*) and send it to forum[at]nomachine[dot]com.


    Using NX protocol, and there is no $HOME/.nx/config/client.crt.  Only player.cfg is there.  All directories are owned by my user.

    I don’t have any $HOME/.nx/R-*, only  F-M* and M-* directories.  The latest session says:

    3233 3233 18:45:06 625.628 Socket: WARNING! Can’t create the IPv6 socket.
    3233 3233 18:45:06 625.837 Socket: WARNING! Error is 97 ‘Address family not supported by protocol’.
    Info: Slave server running with pid 3264.
    Info: Listening to slave connections on port 25001.
    3233 3233 18:45:06 730.617 ClientSettings: WARNING! Creating the list of favorites.
    3233 3233 18:45:06 730.807 Main: Starting NoMachine Client version ‘4.4.12’.
    3233 3233 18:45:06 776.269 OsDetect: Setting os type to ‘CentOs’.
    3233 3233 18:45:06 776.289 Main: Creating a new connection monitor.
    3233 3233 18:45:07 573.413 ClientThread: Creating new thread.
    3233 3233 18:45:07 850.704 MonitorService: Enabled drag and drop feature.


    A problem you are experiencing is related to a way how NX identify host keys. Host keys are recognised with just a hostname without specifying port so multiple services exposed on multiple ports on the same host are treated as one. We are going to fix it soon.

    In the meanwhile, if you are using a enterprise version of NoMachine, you can use SSH protocol or bind your tunnels into separate IPs assigned to loopback interface.

    For example:




Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.