Desktop is not shared

Forum / NoMachine for Windows / Desktop is not shared

Viewing 11 posts - 16 through 26 (of 26 total)
  • Author
  • #32819

    I noticed something.
    If I repeat "%ProgramFiles(x86)%\NoMachine\bin\nxserver" --status several times in a row, the nxnode will sometimes be enabled and sometimes disabled, without me doing anything else but checking the status.
    Seems like nxnode is in a crashing loop, perhaps?


    Additional logs sent on April 8.



    Last night my Windows got updated. This morning I noticed my NoMachine is running and “Desktop shared” is blue and I can switch between “Shared” and “Not shared”. Seemingly the Windows update has fixed the problem. But then I connected to the machine and it went OK up until the point where I should be presented with my desktop. At that point NoMachine client on the machine I was connecting from informed me that there’s no available desktops on the remote machine.
    So, it was looking better after the Windows update, however it is still not working properly.
    After all of that I have decided to restart the services with nxserver –shutdown and then nxserver –startup
    And now the old behaviour came back, as described in this thread.
    I noticed one detail that I think no one described yet. The NoMachine icon in the system tray is constantly appearing and disappearing… my guess is that’s in line with nxnode flapping between enabled and disabled states.


    Could you please send us the file:
    C:\Program Files (x86)\NoMachine\etc\nxdb
    from that Windows?

    It will help with the investigation. Thanks!


    @og00r, I’ve sent the file to forum[at]nomachine[dot]com


    Looks like the update went wrong on your installation.
    There are a few options:
    1) Reinstall NoMachine:
    -Simply remove NoMachine, restart the machine, install a new one and restart the whole computer should help.

    2) Check if the file:

    C:\Program Files (x86)\NoMachine\etc\nodes.db

    exists. (if there is nodes.db.backup or .orig, simply rename it and continue)
    If yes, then run “cmd” as Administrator, go to directory:

    C:\Program Files (x86)\NoMachine\bin\

    and run

    nxserver --updatedb

    and then

    nxserver --restart

    3) If the above file does not exist
    then run “cmd” as Administrator
    go to directory

    C:\Program Files (x86)\NoMachine\bin\

    and run debug command

    nxserver --addtoredis

    and then

    nxserver --restart


    Yours db looks ok, so the problem is somewhere else. I saw your logs but they are only from ProgramData directory and we need also enabled logs from


    You can enable logs manually, and then restart NoMachine with command

    nxserver --restart

    started in cmd which is run as Admin in directory

    C:\Program Files (x86)\NoMachine\bin\

    You can also enable logs with a command from cmd
    here is an article explaining how to do it, and then also restart NoMachine.

    Then you need to gather logs, I prefer the method described here:

    Important for me are logs:
    because looks like on your machine node is started but it closes immediately.


    @og00r, sent to forum[at]nomachine[dot]com


    It looks like there could be some problem with audio interface and it crash. Did you change anything recently related to audio interface?
    Could you try to disable audio?
    To do this please edit as admin file:

    C:\Program Files (x86)\NoMachine\etc\node.cfg

    Find line:
    Uncomment it if it is commented already and set disable:
    AudioInterface disable
    Then restart NoMachine.


    @og00r, I have tried editingĀ  C:\Program Files (x86)\NoMachine\etc\node.cfg and changing AudioInterface to disable and also to disabled (as the comments in the cfg file imply). None of those worked.
    Then I started thinking about what I changed regarding audio and now I have found what is causing these issues. I am working with MIDI a lot as my hobby. I have VirtualMIDISynth and Munt installed for a long time. Lately, I also added Timidity++ Driver and that’s the one that prevents NoMachine from working. Once I have uninstalled it, NoMachine started working again.
    I wonder if there’s anything you could do about it…
    Thank you for all your help.


    @og00r, Thank you.

    Uninstall, reboot, reinstall, reboot and all is now working.

    Too easy – I should have given that a try on basic principles.

Viewing 11 posts - 16 through 26 (of 26 total)

This topic was marked as solved, you can't post.