Details on Gnome-session command options

Forum / NoMachine for Linux / Details on Gnome-session command options

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #11322


    I recently started using an Ubuntu 14 desktop at work in addition to my Windows laptop. I use NoMachine Enterprise client on Windows 7 to remote login to the Ubuntu desktop. After struggling a lot, I was able to get this command from someone to get a proper connection through “Create a custom session” option after clicking “Create a new virtual desktop session”.

    /usr/bin/gnome-session –disable-acceleration-check –session=gnome-fallback

    Now, this command¬†works well for remote access, with no issues, except that the unity launcher has disappeared. Is there any documentation available that shows what options can be set to “–session” in the above command?

    Some more details on how I got here are:

    • Upon connecting to the linux¬†host from my Windows 7 NoMachine Client, there are a few desktop options that show up.
    • “GNOME virtual desktop”, “XDE virtual desktop”, and “Create a custom session”.
    • Since Ubuntu’s unity desktop is based on GNOME, I hope just using the GNOME desktop session would work well.
    • However, the default command that this option looks for doesn’t exist since the node.cfg is in a different location on the linux machine due to the way NX server was setup by my IT department.
    • So, the only option seems to be to tinker around with the custom session and plop in the correct command.

    It would be helpful to understand the details of various commands that can be modified with different options so I can try to get it to work better.




    The list of sessions is described in the ‘/usr/share/xsessions/’ directory and corresponds to the .session files that you can see in ‘/usr/share/gnome-session/session’. The number of available sessions depends on what you have installed on the system.

    Here you can see a few examples:

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.