Disable authorize connections to remote desktop

Forum / NoMachine for Linux / Disable authorize connections to remote desktop

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #18126


    I have an issue with NoMachine request for authorize connection to remote desktop when connecting from Windows machine to Linux machine,

    Although all parameters in configuration file related to DesktopAuthorization are configured as “0”, meaning disabled :

    VirtualDesktopAuthorization 0
    PhysicalDesktopAuthorization 0

    and although trying to check from Linux desktop itself on NoMachine settings , and also there looks like DesktopAuthorization,

    still when we try to connect from windows to Linux we are asked to wait for auth with following message : “…waiting for the desktop user to authorize”

    how can we solve that ?

    Thanks Shaul



    Such behavior is expected when trying to attach, when different user is already connected.

    On the free version of NoMachine it is only allowed for just one connection at once, so if there is one
    connection established, NoMachine will ask current user to disconnect and give 15 seconds to answer.
    If no answer is made the old session should be disconnected regardless.

    To disable this you can enable config key AutomaticDisconnection and set it to 1:

    AutomaticDisconnection 1

    It will cause old sessions to be always disconnected immediately even when different user is logged in.

    Please let us know if it solved the issue or if another behavior is observed or expected.


Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.