Empty list of usb device, nxusb cannot be compiled because of missing relocs_32

Forum / NoMachine for Linux / Empty list of usb device, nxusb cannot be compiled because of missing relocs_32

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #29522


    I’m facing issues with some clients (but not all) trying to connect to a NoMachine server.

    When we try to connect a USB device, the list is always empty. I tried with another client that I know to work, trying to share the same USB device with the same NoMachine server, and I was able to share the device.

    My initial guess was that maybe nxusb.ko is required and not loaded on the client because not in the correct format. But actually, if I try to

    cd /usr/NX/share/src/nxusb && make -f Makefile

    I get :

    make -C /lib/modules/5.3.0-62-generic/build M=
    make[1]: Entering directory ‘/usr/src/linux-headers-5.3.0-62-generic’
    HOSTCC  scripts/basic/fixdep
    HOSTCC  scripts/kconfig/conf.o
    HOSTCC  scripts/kconfig/confdata.o
    HOSTCC  scripts/kconfig/expr.o
    LEX     scripts/kconfig/lexer.lex.c
    YACC    scripts/kconfig/parser.tab.h
    HOSTCC  scripts/kconfig/lexer.lex.o
    YACC    scripts/kconfig/parser.tab.c
    HOSTCC  scripts/kconfig/parser.tab.o
    HOSTCC  scripts/kconfig/preprocess.o
    HOSTCC  scripts/kconfig/symbol.o
    HOSTLD  scripts/kconfig/conf
    scripts/kconfig/conf  –syncconfig Kconfig
    make[2]: *** No rule to make target ‘arch/x86/tools/relocs_32.c’, needed by ‘arch/x86/tools/relocs_32.o’.  Stop.
    arch/x86/Makefile:232: recipe for target ‘archscripts’ failed
    make[1]: *** [archscripts] Error 2
    make[1]: Leaving directory ‘/usr/src/linux-headers-5.3.0-62-generic’
    Makefile:8: recipe for target ‘all’ failed
    make: *** [all] Error 2

    I got this issue in a Ubuntu 20.04 running a kernel 5.something and also on a Ubuntu 18.04 running a kernel 5.3.0-62-generic.   But the compilation works on an ubuntu 18.04, kernel 4.15.0-112-generic .

    Do you have any idea on where this issue might come from ?

    Thank you for your help.



    Make sure your system is configured correctly. Those articles may help you:




    Oh, I’m sorry. Actually , that was a little piece that I didn’t do strictly as you mentioned in the links :

    I did :

    sudo make -f Makefile

    and I should have done

    sudo su

    make -f Makefile

    That solved it for the 5.3.0-62-generic ; I will check if it solved the problems on the other OS and keep you informed.

    Thanks for your help.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.