EndeavourOS X server not found

Forum / NoMachine for Linux / EndeavourOS X server not found

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #46322
    jamat13
    Participant

    Hi

    I decided to move my main machine to endeverOS (arch linux). So I setup a test machine, got every thing working, including NoMachine then did my main machine.

    I cannot get the main machine to work reliably. I have had it work a few times, but usually not.

    The only significant difference is the test machine runs plasma5 and main machine runs LXQT. The login screen should eliminate desktop.

    [seagull] /home/jam [501]% sudo /etc/NX/nxserver --restart
    [sudo] password for root:
    NX> 162 Disabled service: nxd.
    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.
    [seagull] /home/jam [502]% ps -ef |grep X
    root        2685     993  0 Dec13 tty2     00:01:21 /usr/lib/Xorg -nolisten tcp -background none -seat seat0 vt2 -auth /run/sddm/xauth_qMAARU -noreset -displayfd 17
    nx         17484       1  1 05:05 ?        00:00:00 /usr/NX/bin/nxserver.bin --daemon
    nx         17516   17484  0 05:05 ?        00:00:00 /usr/NX/bin/nxd
    jam        17543   17426  0 05:05 pts/0    00:00:00 grep X
    [seagull] /home/jam [503]%

     

    I see nxnode is not running

    [seagull] /home/jam [503]% ps -ef |grep nx
    nx         17484       1  0 05:05 ?        00:00:02 /usr/NX/bin/nxserver.bin --daemon
    nx         17516   17484  0 05:05 ?        00:00:00 /usr/NX/bin/nxd
    jam        17755   17426  0 05:25 pts/0    00:00:00 grep nx

     

    If I need to submit logs can I clean out all logs nefore starting. Do I just do sudo /etc/NX/nxserver –debug –enable daemon and disable?

    Can anyone tell me what is wrong please?

    James

    PS “connecting ..” and wheel just turns

    I copied node.cfg from working machine to non working machine

    NoMachine – Version 8.10.1 (Free desktop)

    viewer makes no difference linux/mac

     

    #46338
    jamat13
    Participant

    OK I’ve now confirmed on both test and main machines:

    Running plasma X11 operation is normal

    Running lxqt main machine: login wheel turns, test machine: good display but mouse <clicks> totally ignored.

    #46345
    Britgirl
    Participant

    We cannot be sure that these problems are not coming from the fact that you are installing from the AUR repository. We are not aware of any issues with detecting LXQT sessions. So, what you should do is try the packages from our website:

    uninstall:

    sudo /usr/NX/scripts/setup/nxserver --uninstall

    download and install:

    wget https://www.nomachine.com/free/linux/64 -O nomachine.tar.gz
    sudo tar zxf nomachine.tar.gz -C /usr/
    sudo /usr/NX/nxserver --install redhat
    #46358
    jamat13
    Participant

    I did not mean to imply NoMachine was in anyway defective, I’m exploring and I really appreciate help thanks 🙂

    I installed the NoMachine version. I post picture1 saying “No X server …”

    I then tried create your own server

    Picture2

    Puzzling things:

    If my *session* is plasma (X11) then NoMachine works normally. (Not only for desktop but login screen too)

    I did already do the PKGBUILD edit

    This is the Downloaded version

    [seagull] /home/jam [511]% !487
    sudo /etc/NX/nxserver –restart
    [sudo] password for root:
    NX> 162 Disabled service: nxd.
    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    nxnode runs on plasma session not on lxqt session.

    Only the first connection said “No Server” all subsequent connects go straight to picture2

    I use NoMachine many times daily, If I can’t solve then I’ll change distro.

     

    #46379
    jamat13
    Participant

    Houston we have a problem …

    I have used NoMachine with lxqt on openSuSE many times over the years.

    So overwhelmed by Arch linux I reinstalled Tumbleweed. Downloaded the rpm and *nearly same* problem.L
    [seagull] /home/jam [332]% sudo /etc/NX/nxserver –restart
    [sudo] password for root:
    NX> 162 Disabled service: nxd.
    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.
    [seagull] /home/jam [333]% ps -ef |grep X
    root      1661  1659  0 21:01 tty2     00:00:00 /usr/bin/Xorg.bin -nolisten tcp -background none -seat seat0 vt2 -auth /run/sddm/xauth_znXojC -noreset -displayfd 16
    nx        3750     1  1 21:06 ?        00:00:00 /usr/NX/bin/nxserver.bin –daemon
    nx        3798  3750  0 21:06 ?        00:00:00 /usr/NX/bin/nxd
    jam       3855  3572  0 21:06 pts/1    00:00:00 grep –color=auto X

    The difference is that I *can* login to NoMachine x-server.

    Please help me find WHY. I will try, but I’m sure plasma desktop will give me the physical display.

    I should be clear from above but there is no Wayland.

    #46380
    jamat13
    Participant

    OK this is bizare but repeated and confirmed:

    openSuSE Tumbleweed rpm downloaded, 8.10 free desktop

    Screensaver off, display, X server not found

    killall lxqt-session

    login screen

    login black screen

    killall lxqt-session

    login screen, set plasma-X11

    login, works normally

    logout

    login screen, set lxqt-session

    login, normal display, no mouse click

    So it looks like

    no X-server == no mouse clicks (I see pointer)

    lxqt-session == no mouse clicks (I see pointer)

    #46381
    jamat13
    Participant

    <sigh> There are many aspects of Ubuntu I don’t like (we decree you shall …) but I installed Lubuntu 23.10 and everything works out the box. (including mouse, screensaver). This version of Lubuntu runs Xorg.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.