Error 138 from Win7 to OSX 10.9

Forum / NoMachine for Mac / Error 138 from Win7 to OSX 10.9

  • This topic has 2 replies, 3 voices, and was last updated 10 years ago by gsw.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #3881

    I have installed the Enterprise Client v4 on Windows 7 x64 (I didn’t want this machine to be a server) and the free client/server bundle v4 on OSX 10.9. Both machines are on the same LAN.

    I am trying to connect from the client to the server (I have double checked and tried both the hostname and the IP address of the server), but I get error 138, “connection timed out”. To rule out firewall issues, I have disabled the firewall on the OSX machine; the Windows firewall is not blocking outgoing connections.

    The NoMachine icon on the menu bar in OSX shows the NX service is set to autostart and it is started, listening on port 4000. But I still get the error like the server was not available.


    Logs can be useful. You can gather them as explained in and send to forum[at]nomachine[dot]com.

    Thank you.


    Not sure if this pertains to your issue but if you are connecting via WIFI check your router settings and try turning on protect mode.

    My router is a Belkin and protect mode resolves issues with 802.11b traffic.

    My windows laptop (client) is 802.11n and my MacMini (server) is 8.2.11b.

    As soon as I enabled this setting my issues was resolved.

    Hope this helps



Viewing 3 posts - 1 through 3 (of 3 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.