Error is 64: Host is down

Forum / NoMachine for Mac / Error is 64: Host is down

Tagged: ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #7474

    Very confused here.

    I’m running the free version 4.6.4 on all machines referenced

    I’ve got a Mac at home (laptop) and a Windows machine (laptop) at work.  I’ve had no problem connecting from my Mac laptop (Yosemite 10.10.3) back to my husband’s Mac at home (yay, Windows 7) but when I try to access my Windows machine from my Mac laptop at home I get “Error is 64: Host is down”.  My fellow worker was at my Windows machine and said there were no problems connecting to the internet.  I have no problems connecting to the internet from home. My office is not part of a big company, no firewalls (other than what may be on my machine).

    The part that does seem odd is that when my fellow opens NoMachine on my PC there is only one set of nx:// numbers.  The 3 little dots show up briefly, under the first set of numbers, then disappear and only one set of numbers appear.

    With our Macs I see two sets of numbers;

    the first has groups of nx://3digits.3digits.1digit.1digit

    the second has nx://2digits.2digits.3digits.2digits:5digits.

    on the PC there is only: nx://3digits.3digits.1digit.3digits.

    I find some of the verbiage used on these forums to be higher level computer terms which I am not that familiar with but I can’t find an error 64 anywhere.

    I would be deeply appreciative of any assistance with this!!!   :-}



    Hi Michelle,

    an IP address starting with 192.168.x.x is typical of a LAN network, and this is what you use to connect from one Mac to your husband’s Mac at home (you are on the same network). Using a LAN IP address in the ‘Host’ field when connecting to any computer over the Internet won’t work. You see something like this in your first set of numbers, I take it.

    The second set of numbers is what you should use to connect to those computers from another machine over the Internet. The last five digits is the port. (You can see an example in Screenshots 1 here: and

    To connect to your Windows PC you need this second set of digits. Your Windows computer is showing only the LAN IP address. This is ok for connecting to it, let’s say, from a colleague’s computer in the office.

    It can be that your office router doesn’t support UPnP. Or that our UPnP doesn’t support your router 🙂 Anyway this shouldn’t affect your ability to connect, even from the outside. Many routers that don’t support the query for the external IP still accept the commands required to enable port forwarding. If that’s your case, you will have to configure the port forwarding by using the router admin interface. This is normally a Web application running at Is there someone at the office that can do this for you? By default the port is 4000 but it can be changed to another.

    NoMachine 5 (coming soon) will allow you to connect to your office PC without having to know this IP address. This would be ideal in your case.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.