Error: No available sessions on this server

Forum / NoMachine for Mac / Error: No available sessions on this server


Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #3286

    I first had authentication problems and commenting auth required use_uid in /etc/pam.d/su solved that issue.

    Now I am able to login, but the NoMachine client on my MacOSX complains of “No available sessions on this server”. I did try looking at solutions in the forum and none seem to have solved my issue. Can you please let me know which log files to look at in order to debug this issue or even better a solution?

    Note: Machine connecting from : MacOSX (running 4.2.21_1 for MAC)

    Machine connection to : Rhel 6 (running 4.2.21._1_i686.rpm package)



    Server side logs will be helpful.

    Please follow the instructions here and either attach them to your reply or forward them to issues[at]

    Additionally please:

    – provide a output from ‘ps -ef’ command running as root;

    – tell us a exact version of RHEL;

    – tell us if it’s a headless server or you have a desktop (Gnome, KDE) actually running;


Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.