Errors during installation on Windows 11

Forum / NoMachine for Windows / Errors during installation on Windows 11


Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #41449


    I tried to install NoMachine client on a Lattidue 5520 Windows 11 but right after opening the installing exe I’m getting a lot errors with similar message “Cannot find an entry point for BN_is_Negative in library C:\Program Files\NoMachine\binn\libssh.dll”. The error itself is always the same the entrypoint and dll just differs(CRYPTO_zalloc at libnx.dll, ASYNC_WAIT_CTX_free at libssl.dll). If I just keep pressing OK the installation will finish but the service will not start at all.

    I’d appreciate any help, thank you.


    Can you tell us how you downloaded the package and installed? i.e what browser did you use and how did you open the package? We’ve recently discovered an unusual behaviour in our packages when downloading via Firefox  that we are investigating that causes the above error.

    For the time-being, can you uninstall completely, re-download using a different browser, browse to the package using the Windows file explorer and install from there? Reboot again.



    Hello @Britgirl and all,

    I’ve got exactly the same problem (some error messages about missing entry points for this function or that) during installation. Although I’m on x64 Windows 10. Yes, I did use Firefox to download the installation .exe (nomachine_8.2.3_4_x64.exe). But, to be honest, your reply (that Firefox is the culprit) sounds dubious. I just re-downloaded the .exe with Google Chrome, and the downloaded file is exactly the same as what Firefox downloaded (I compared with fc /b) .

    So no, it does not look like Firefox has anything to do with this. is broken, please fix it or at least give a link to an older (“stable”) version.


    Hi, I didn’t say that Firefox was the culprit. We are still investigating an unusual behaviour that we’ve reproduced when initiating the download of and installation of the 64-bit package from the FF browser window, even when the correct NoMachine installation procedure is followed.

    I just re-downloaded the .exe with Google Chrome, and the downloaded file is exactly the same

    The same file it is indeed, but I don’t know whether you initiated the reinstall of the package by browsing to the appropriate folder using Windows Explorer. So I’m not sure whether you mean the same error occurred.

    Either way, a workaround is, whilst we investigate, to download the 32-bit package and install that. Please make sure you follow the correct uninstallation procedure, rebooting where requested, and then follow the correct installation procedure of the 32-bit package, rebooting where requested. Thanks.


    ilgaz@hp:/mnt/c/Users/ilgaz/Downloads> sha256sum nomachine_8.2.3_4_x64.exe
    c75b8d8b92e76c20bd28ec038bf371bfc1866c0733aac2e2edb921bfb104f834  nomachine_8.2.3_4_x64.exe
    ilgaz@hp:/mnt/c/Users/ilgaz/Downloads> sha256sum “nomachine_8.2.3_4_x64 (1).exe”
    c75b8d8b92e76c20bd28ec038bf371bfc1866c0733aac2e2edb921bfb104f834  nomachine_8.2.3_4_x64 (1).exe

    Files are exactly the same. Wonder if it is related to how browsers “execute” files? I will report it to Firefox/Mozilla


    Reported the issue to Mozilla/Firefox at and Webcompat at


    Hi, I had the same issue with the first error messages being ‘the procedure entry point BN_is_negative could not be located in the dynamic link library libssh.dll’ (Followed by several other error message boxes) in Windows 11 64 bit.

    I downloaded with FireFox and I can confirm the downloaded x64 file is not the issue but trying to install by clicking directly on the download in the browser is. When I opened the same downloaded file in Windows 11 file explorer and installed from there it installed fine.

    So the solution is to download the file and then open it from the download folder using file explorer to install it. It seems that @Ilgaz is correct in that it it is related to how browsers “execute” files.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.