External Port

Forum / NoMachine for Windows / External Port

  • This topic has 2 replies, 3 voices, and was last updated 8 years ago by irek.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #11505

    I have installed the free version (5.1.26) today on 2 macs and 1 W7 machine locally and on 1 mac in another city.


    1) All 3 local machines can connect and see each other easily within the LAN behind the same router.  All are running the latest Norton.  The remote access works fine with no firewall or other changes other than the basis setup steps from your tutorial.

    2) The 2 local macs show an external IP with port on the NoMachine welcome screen (e.g., ###.###.###.###:#####); no UDP issues with the router.

    3) The W7 box does not show an external IP with port on its NoMachine welcome screen (e.g., all that shows is the W7’s internal IP = 192.168.###.###).    Why is there no external port?  Also, when I go into settings>server preferences there is no GW port listed and if I try to check the box (double clicked the NX line), the Gateway port is unchecked and port 21380 is in the port number box but is dithered out.  If I check the Gateway Port box the new checkmark is also dithered out.  By waiting about 30 seconds the error “Failed to map the port on the gateway” appears and removes the checkbox.  I have turned off Norton and retried with no success.  Why can the Macs map the port but the W7 box cannot?

    4)  The Mac in the other city was setup and acts like the W7 box in 3).  No external IP shows up and manually setting the Gateway Port provides the same behavior.

    5) When the local Macs try to connect to the Mac in the other city, the connection fails under proxy or no proxy or nx or ssh.  Under ssh NoMachine prompted “are you sure…” and showed the MAC_ID of the mac in the other city.  I responded that I was sure and hit OK, but the connection failed anyway.  Since the Mac in the other city would not automatically map the port on the gateway, I will use the instructions from the forum regarding no UDP/NAT/Port Forwarding to see if that resolves.


    1) Why is the W7 box not mapping the port when the Macs do?  All 3 boxes are wired directly to the first switch behind the router.

    2) What changes need to be made to the W7 box to allow the mapping (tried tuning off any firewalls, etc. with no affect)?

    3) What makes my machine accessible remotely: a) leaving the computer on and the application running? or b) leaving the computer on and the service is running?

    4) In one sentence what is the basic difference between NoMachine free (peer-to-peer) and NoMachine cloud?

    5) Will NoMachine cloud run on FreeBSD (for UNRAID)?


    1) Setup a “test your connection” server for newbies.  The server can present a plain Linux desktop with a “success” check box and a timer to kick out lingerers.

    2) Change “Host” to “Destination IP” on the “New Connection” page.

    3) Present “Your (external) IP with port number (###.###.###.###:#####) in the header between “Recent connections” and “NoMachine” on the “Recent connections” page.  That way when I want someone to connect to my machine temporarily, I can easily tell them my IP connection info.

    4) An extra benefit would be to add a temporary UID that could be shared with the remote person good for the duration of the connection.  Sometimes I want to share my screen and what’s going on in/on my computer with someone.  Right now I have to give the remote user my UID/pwd or create a guest account for them (which may not have access to what I’m showing).

    5) Turning the NoMachine service on and off is buried behind many clicks.  Since the “home” screen seems to be “Recent connections”, add a toggle there.


    Hi, thanks for your feedback 🙂

    I can answer straight away on a few of your points/questions. One of our devs will be looking in to the issues you’ve reported in 1) and as a consequence will also cover 2) and 3) in your conditions list.

    3) What makes my machine accessible remotely: a) leaving the computer on and the application running? or b) leaving the computer on and the service is running?

    To be able to access your machine you need to leave your computer on, and the NoMachine service running (check the status in the icon tray that !M is visible).

    4) In one sentence what is the basic difference between NoMachine free (peer-to-peer) and NoMachine cloud?

    Cloud Server provides access via the browser, so you don’t need to install NoMachine on the connecting client.

    5) Will NoMachine cloud run on FreeBSD (for UNRAID)

    The supported platforms on which you can install NoMachine (server side) do not include FreeBSD. We are currently evaluating whether to add it.

    With regards to your suggestions, we really appreciate you submitting them. We’ll analyze them one by one and see what improvements can be made. I’ll point out at this stage that point 4 in your suggestions list will be solved when we release NoMachine Network (was Anywhere). You can read more about this here: https://www.nomachine.com/FR07J02731


    Hello tweedyc,

    About issue with not seeing external IP on welcome page on Windows 7

    – Please check that UPnP is enabled on nxserver.

    Check the key ‘EnableUPnP’ in server.cfg if it is set to NX, if not set it and restart nxserver.

    – Can you please turn off any firewall/security applications such as Norton and others.

    We will need debug NoMachine Cloud server logs from Windows machine to investigate further. Please follow the instructions here:


    And then please do those steps:

    As it can take some time to reply from the router, so after nxserver starts up check both way:

    – Start nxplayer and check welcome page to see if external IP shows up, if not close nxplayer and check again after some time.

    – Open CMD as administrator and call that command inside NoMachine installation directory

    ‘ nxserver –upnpstatus ‘

    Repeat that steps few times if external IP wouldn’t shows up.

    Send them to forum[at]nomachine[dot]com

Viewing 3 posts - 1 through 3 (of 3 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.