Failed to connect after OS upgrade

Forum / NoMachine for Windows / Failed to connect after OS upgrade

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #10674


    sorry for all the tickets but I figured it would make sense to open separate tickets for separate issues.

    – NoMachine product and version on local and remote machine (free version, Workstation, etc).
    Free version v5.1.9 on both remote and local

    – Whether the problem arises connecting to a physical or a virtual display.
    headless (virtual)

    – Remote and local Windows/Mac/Linux version (Windows XP/7/8, OS X 10.x, Ubuntu xyz, Mint x.y, etc.).
    Windows 10 – local Max OS X – remote

    After upgrading the operating system, the Mac automatically rebooted itself. When I tried to log in via NX, it detected the Mac and prompted me for the password, but the spinning wheel kept going forever with the message “waiting for the server to authorize the remote desktop session” or something along those lines. I tried several times, even restarting NX on the client, but still no luck.

    At some point I gave up and connected a physical display to see what’s happening on the mac and it was displaying the log in screen. I logged in and then tried NX again and this time it worked.

    is it possible that after an OS upgrade, the Mac prevented NX from connecting? if that’s the case, is there any solution or workaround?

    Thank you,


    Hello rob8861,

    We managed to reproduce the problem. It seems that some upgrade operations are performed after reboot. Post-reboot configuration is done under ‘_mbsetupuser’ account. For some reasons this user is detected as desktop owner on login window and NoMachine Server waits until he accepts the incoming connection. Problem should disappear after next OS reboot. You can check this Stack Overflow thread for additional information:

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.