Fedora 39 pipewire – no audio

Forum / NoMachine for Linux / Fedora 39 pipewire – no audio

Tagged: ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #45980

    Hi all,

    Started a clean install of Fedora 39 to use as a NoMachine host.

    When trying to get the audio working, I don’t see anything other than Dummy Output from the Gnome settings…

    # pactl info
    Server String: /run/user/1000/pulse/native
    Library Protocol Version: 35
    Server Protocol Version: 35
    Is Local: yes
    Client Index: 55
    Tile Size: 65472
    User Name: netwiz
    Host Name: fedora-rdp
    Server Name: PulseAudio (on PipeWire 0.3.84)
    Server Version: 15.0.0
    Default Sample Specification: float32le 2ch 48000Hz
    Default Channel Map: front-left,front-right
    Default Sink: auto_null
    Default Source: auto_null.monitor
    Cookie: 10ed:7204

    I checked /usr/NX/etc/node.cfg and the following is set:
    AudioInterface pipewire

    What else should be checked?



    Are you able to hear sound from your machine outside NoMachine session? I’m not sure if it’s possible if you only have auto_null. Your built-in device should be set as the default sink, or some other physical device, i.e. headphones or external speakers. When NoMachine makes a connection between two machines, it connects to the default sink and captures its output data. This means that even if NoMachine is able to connect to auto_null (Dummy Output), if auto_null doesn’t receive any data, you don’t hear anything on the client side.

    If your Fedora is a virtual machine, you should probably connect it to the speaker of the physical machine and enable audio in virtual box settings (or any software you’re using for virtualization) and then test the connection via NoMachine.




    I came back to this after finding out that pipewire is not supported for Virtual Desktops….

    As such, I reverted to pulseaudio. The nxnode --audiosetup didn’t work as there was no /etc/pulse/client.conf.

    I copied that in from somewhere in /usr, and ran nxnode --audiosetup again, and after that point, all works.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.