Fedora 40 + NoMachine not working

Forum / NoMachine for Linux / Fedora 40 + NoMachine not working

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #48728
    CRCinAU
    Participant

    Hi all,

    I’ve been trying to fire up a brand new Fedora 40 VM with NoMachine + Virtual Desktop and had nothing but issues.

    I either manage to connect, but it tells me there are no desktops available, or say that it can’t create a desktop.

    I did a fresh install of Fedora 40 KDE Spin, then installed NoMachine and changed CreateDisplay to 1 and then set DisplayOwner to my username.

    Has anyone managed to get a working KDE desktop with NoMachine in Fedora 40?

    #48737
    Britgirl
    Keymaster

    Hi,

    your issue could be related to this Trouble Report: https://kb.nomachine.com/TR05V11141.

    If you send us the logs from the server side (follow the instructions here) we can verify them. Follow the instructions here and either submit here as a zip or send directly to forum[at]nomachine[dot]com.
    https://kb.nomachine.com/DT07S00243.

    #48739
    CRCinAU
    Participant

    Hi Britgirl – good to see you’re still active ūüôā

    I’m not 100% sure that’s the only case. To keep the details in the same place, I did install nomachine on Fedora 39 – which worked perfectly. After installing all the latest updates to Fedora 39, this also broke and seemed to fail in the same way. Fedora 39 is still on KDE Plasma 5.

    I will however do a fresh install of Fedora 40 – with no messing around attempting to make it work – and post the logs as requested.

    #48741
    CRCinAU
    Participant

    For the benefit of the forum, this is my current status:

    1) Install fresh Fedora 40 VM
    2) Install nomachine
    3) systemctl set-default multi-user.target
    4)¬†Add¬†‘selinux=0¬†audit=0’¬†to¬†grub¬†kernel¬†cmd¬†line
    5) Reboot

    The logs attached are at this point in time.

    I note that DefaultDesktopCommand was not set for the KDE desktop.

    As such, I then changed the DefaultDesktopCommand in node.cfg to:
    DefaultDesktopCommand "dbus-launch --exit-with-session /usr/bin/startplasma-wayland"

    Then restarted NXServer via:
    root@remote-apps:/usr/NX/etc# ../bin/nxserver --restart
    NX> 162 Disabled service: nxd.
    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    I noticed that the following was set in /usr/NX/etc/node.cfg:

    DefaultDesktopCommand "/etc/X11/xinit/Xsession default"

    Likely, this wasn’t going to work, so I edited it to:

    DefaultDesktopCommand "dbus-launch --exit-with-session /usr/bin/startplasma-wayland"

    This kind-of-worked – but things were VERY slow. I then installed the plasma-session-x11 package, and changed the line to:

    DefaultDesktopCommand "dbus-launch --exit-with-session /usr/bin/startplasma-x11"

    After a reboot, I was able to log in – and this seems to work – which is rather strange, as I couldn’t get this working at all last time – even though I did the above steps as well.

    I’m pretty sure that wayland has worked before for KDE – but I’ll keep tinkering to see if / what I can break ūüôā

    #48748
    Britgirl
    Keymaster

    Hi,

    Glad to know it’s now working, but we can keep this topic open for a while in case you need to report back.

    After installing all the latest updates to Fedora 39, this also broke and seemed to fail in the same way.

    This could be related to this TR https://kb.nomachine.com/TR04V11131 but it’s hard to say without seeing logs from that server as well.

    #48757
    Britgirl
    Keymaster

    We got the logs and will let you know.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.