Focus gets locked to a window or subwindow

Forum / NoMachine for Linux / Focus gets locked to a window or subwindow


Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #25925

    Server: CentOS 7 / Gnome 3.28.2 / NoMachine free 6.9.2 / Headless VM

    Client: macos Catalina (10.15.3) / NoMachine free 6.9.2

    Connecting to a virtual display.

    Focus gets locked to a window or sub-window very often. Cannot access other windows or other sub-windows (panels) of same application.

    If I disconnect and reconnect things return to normal for a while.


    Hi electrosaur,

    does this occur with a specific application? Any idea what could be triggering the issue (e.g. a special key combination)? Did you try to press and release modifiers (like Ctrl or Alt) to see if any of them got stuck?


    Don’t think this is related to the application, because the focus gets locked on different applications at different times: IntelliJ Idea, Firefox, gterm, …. When the focus is locked, if I try to move or resize any window it will move or resize only the window to which the focus is locked.

    It happens at random – I don’ think its some key combination I’m pressing. But I will watch carefully to see if that is the case.

    I’ve tried pressing modifier keys, and combination of modifier keys but it doesn’t unlock the focus.

    There was a similar issue with an earlier version of NoMachine (see There the advice was to try running ‘xdotool key XF86Ungrab’. I tried that, and it seems to work sometimes but not always.

    It does seem to be related to the bandwidth of my connection. If I am hardwired to my router it almost never happens. If I am connecting over WiFi it happens all the time.

    Disconnecting and reconnecting *always* fixes it (for a while).



    you can also try XF86_ClearGrab to terminate the application that owns the grab, or XF86LogGrabInfo to dump info about the application. Output from XF86LogGrabInfo will appear in the ‘/usr/NX/var/log/node/C-<hostname>-<display_number>-<session_id>/session’ file.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.