Fonts broken in NoMachine window

Forum / NoMachine for Linux / Fonts broken in NoMachine window

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #38962

    I’m running NoMachine on KDE Neon and its been working fine for months after I switched back to X from Wayland.

    After the updated recently I’m getting all the fonts microscopic again (I’m on a 4K desktop and I think its ignoring the zoom settings).

    Makes it hard to work with 🙂

    Screen shot attached.


    Hi, let me understand better:

    1) you’ve been using Xorg (not Wayland) connecting with NoMachine and had no problems up until recently?

    2) all of a sudden you’re getting small fonts in the NoMachine player? What have you changed on the host, in the time it was working and when the font problem started? Did you only update NoMachine to 7.10?

    2) have you followed your own tips from your original post in e.g reboot?

    3) what is the ‘zoom level’ that you mention?

    We’ll try and reproduce it here. I’ll write what I wrote last time:

    Do the following, open a terminal on the affected host execute ‘xdpyinfo’ and ‘xrdb -query -all’ . What’s the output?

    If you change the font in the NoMachine Player settings, does the problem go away?



    Hi, that’s for getting back to me again 🙂

    So, as far as I know, other than system updates, nothing changed this time.

    The xrandr config I’m using is

    xrandr --fbmm 6912x2160 --output eDP-1-1 --pos 0x0 --mode 3840x2160 --scale 0.8x0.8  --left-of  DP-1-2 --output DP-1-1-2 --auto --scale 0.9999x0.9999 --primary

    Although the tiny fonts persist on both monitors with different scale values (that’s the zoom I’m talking about).

    The basic display configuration settings in KDE have Global Scale at 100%

    xrdb -query -all
    *customization: -color
    Xcursor.size:   24
    Xcursor.theme:  breeze_cursors
    Xft.antialias:  1
    Xft.hinting:    1
    Xft.hintstyle:  hintmedium
    Xft.rgba:       rgb

    xdpyinfo output is attached.

    I tried switching back to Wayland and back to X but nothing changed this time.



    I have just worked out where the font settings are (pretty tricky when everything is so small) and changed them to 28 point, and the fonts are now readable.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.