Force login to physical desktop each connection?

Forum / NoMachine for Linux / Force login to physical desktop each connection?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #22363

    For some reason, a NoMachine server that I connect to has started allowing NoMachine to directly access the desktop, whereas previous, when I connected, it showed the console login screen, and I had to log into that to access the desktop

    Now it’s just logging me straight in. What’s changed and (more importantly) what do I do to revert to the old behaviour ?

    I’ve tried deleting and recreating the client connection, but it still does it.




    One thing that has also started happening which never used to, is I am getting a message:

    “Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?”


    Something has definitely changed and it happened Friday 17th May between 15:00 and 17:00 (when I rebooted).

    How can I tell ??


    root@DebServer64:/usr/NX/etc# /usr/NX/bin/nxserver –history

    Display Username Remote IP      Session ID                       Date                Status    Node           Type
    ——- ——– ————– ——————————– ——————- ——— ————– ———————
    1002    <me> C83E52E2413B3C3A44087441788D4D9E 2019-05-20 10:23:31 Connected localhost:4000 physical-desktop
    1001    <me>      537BAD14602419F1A046F59F71B7EDA8 2019-05-20 10:23:16 Connected localhost:4000 nxvfb
    1001    <me>      1B899ABD747C0F4B2630D5537416A1A6 2019-05-19 17:47:37 Unknown   localhost:4000 nxvfb
    1002    <me> 547A00D1AE4DB49948A68D52C30A978D 2019-05-19 17:47:36 Finished  localhost:4000 physical-desktop
    1001    <me>      120334A8C4DD86401BE1A514790BE585 2019-05-19 17:42:08 Unknown   localhost:4000 nxvfb
    1002    <me> AA20A4B78F52D06DA27A58B7B07578FE 2019-05-19 17:42:07 Finished  localhost:4000 physical-desktop
    1001    <me>      2D4B96A508E82A641D340E1282A89DFE 2019-05-19 17:40:41 Unknown   localhost:4000 nxvfb
    1002    <me> 121CC38040B6C77AB18F4E5AEFBE3617 2019-05-19 17:40:40 Finished  localhost:4000 physical-desktop
    1001    <me>      8B2721312B3CE930AFA99D14054D232E 2019-05-19 17:37:19 Finished  localhost:4000 nxvfb
    1002    <me> E089A58AAB8B33AF1C77FD41AFCA26C9 2019-05-19 17:37:18 Finished  localhost:4000 physical-desktop
    1001    <me>      AE0EAB375E614FF4E336A7F312091148 2019-05-19 12:29:57 Unknown   localhost:4000 nxvfb
    1002    <me> 9885DF6930AC9CC4C19FF54CFA9AD775 2019-05-19 12:29:56 Finished  localhost:4000 physical-desktop
    1001    <me>      3E270F8277A0CB426AC70DA0D234CB31 2019-05-19 12:29:37 Unknown   localhost:4000 nxvfb
    1002    <me> 81FA83041818252EFF90B82F3EF2FC4A 2019-05-19 12:29:36 Finished  localhost:4000 physical-desktop
    1002    <me> C7D056942A0A24009E7DFFC75C233A4B 2019-05-19 12:12:40 Finished  localhost:4000 physical-desktop
    1001    <me>      28ED4B6310C4A93B82A5F8D7AC67D2ED 2019-05-19 11:36:00 Unknown   localhost:4000 nxvfb
    1002    <me> 7C0236499F65EC1DEC42941D3ED56CA2 2019-05-19 11:35:59 Finished  localhost:4000 physical-desktop
    1001    <me>      C46EB1B5AF9510C9B05263E24D3230ED 2019-05-17 18:13:21 Unknown   localhost:4000 nxvfb
    1002    <me> B725AC3DE242A8A79C65CED9A85231AB 2019-05-17 18:13:20 Finished  localhost:4000 physical-desktop
    1001    <me>      AE8D6FC2BDAE83167C003CBDA9E1469D 2019-05-17 17:36:42 Unknown   localhost:4000 nxvfb
    1002    <me> FFD539233FE076A5B5DAFF1B1FDB5F17 2019-05-17 17:36:41 Finished  localhost:4000 physical-desktop
    1001    <me>      AF788CB8085A2459F606415124D0B1B5 2019-05-17 17:03:19 Unknown   localhost:4000 nxvfb
    1002    <me> B3A7CC04EC614C84303E93EF0E1FD084 2019-05-17 17:03:18 Finished  localhost:4000 physical-desktop
    1002    <me> 2C0E73D69DD351036DD5BA3CB1320127 2019-05-17 15:29:10 Finished  localhost:4000 physical-desktop
    1002    <me> 918776577BAC26A31976B2FA5B6C868B 2019-05-17 11:25:46 Finished  localhost:4000 physical-desktop
    1002    <me> 5C032D100BC941880F94996199184D53 2019-05-17 11:17:57 Finished  localhost:4000 physical-desktop
    1002    <me> 625DB467FA813BD00267B3D9A32E70E2 2019-05-17 10:14:16 Finished  localhost:4000 physical-desktop
    1002    <me> D3A47A0374DCA3AD55D01ED7020877D0 2019-05-16 17:34:14 Finished  localhost:4000 physical-desktop
    1002    <me> 97854D8175F0E2CE07E6D1F807187B76 2019-05-16 16:26:16 Finished  localhost:4000 physical-desktop
    1002    <me> BE9DC3975836726533820AB397525EF7 2019-05-16 14:52:14 Finished  localhost:4000 physical-desktop
    1002    <me> C5C940CE50933295D5F0F72FF6E1CF6F 2019-05-15 10:01:38 Finished  localhost:4000 physical-desktop
    1002    <me> 7515C23D01CAA1AE7EA9B2CC8B44692F 2019-05-14 17:19:46 Finished  localhost:4000 physical-desktop
    1002    <me> 653619E76F0FAD99C5220407F814370B 2019-05-14 10:45:01 Finished  localhost:4000 physical-desktop
    1002    <me> D7CDB59E2986D57592607B8B14AB1806 2019-05-13 17:51:02 Finished  localhost:4000 physical-desktop
    1002    <me> B91FCC2A0F093711FCC7C2E321D8B658 2019-05-08 14:03:01 Finished  localhost:4000 physical-desktop




    This new information provided good insight into what is going on.

    When you get the message:

    Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?

    In the player, this means that for some reason the local (physical) session detection mechanism failed,
    and NoMachine could not make the session available.

    Selecting ‘yes’ as the answer to this question would make the server create a virtual session
    to work on. So the behavior was different, because you were never connecting to the physical
    session, which would have to include the Login window screen.

    So to the problem itself is why NoMachine failed to detect the session. There can be a few options here:

    1. The Xserver started after the nxserver started during the system startup, and you have connected before the detection could have been completed. Then, since you selected “yes” as mentioned earlier and created the virtual desktop, you can now only get the access to this virtual session.

    So the first thing to try is to check the /usr/NX/etc/server.cfg file and make sure that ‘CreateDisplay’ key is commented or set to 0. And then run:

    # /usr/NX/bin/nxserver –restart

    and see if the physical session was detected and made available. Please remember the virtual session will be lost when restarting the nxserver, so saving any work or keeping unfinished processes until they finish is advised.

    2. After operating system restart, the Xserver providing service is disabled.

    If you have physical access to this machine and/or can confirm the Xserver is running, please do so. With only console access the easiest method is to search process tree for X/Xorg processes:

    # ps -ef | grep X

    or for wayland processess

    # ps -ef | grep ayland

    If there is nothing running, you will have to re-enable the service from the console, and then restart the nxserver.

    3. If the Login Window is running on Wayland, please try to disable it, so the simple Xserver is used, then restart the nxserver and try to connect again.

    4. If everything fails, the cause is with the session detection procedure, and to help further, we would require the logs from the nxserver startup.

    Please refer to this article on how to collect logs: (“How to gather debug logs for support requests”)

    And please run:

    # /usr/NX/bin/nxserver –restart

    after enabling logs, so the detection procedure made on startup is logged.

    After gathering logs, please send them to forum[at]nomachine[dot]com using the title of that forum’s
    thread as the mail’s subject.



    Many thanks for replying – and it seems you have nailed it 🙂

    1) For some reason my server.cfg had CreateDisplay
    set to “1”. I changed this. Then issuing the nxserver –restart command threw up an error:

    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 162 Disabled service: nxd.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    AHA ! – So there really was no XServer running. For my particular machine, running:


    sudo service lightdm restart


    seemed to do the trick. The nxserver –restart then seemed happy. And connecting to the machine, I got the login window I used to get.


    Case closed !

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.