Forwarded USB device detected by Windows but not software

Forum / NoMachine for Windows / Forwarded USB device detected by Windows but not software

Tagged: , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #25665


    I am trying out NoMachine to see if it can meet my use-case, but I’m having an issue with USB device forwarding.

    My NoMachine client is on a Windows 10 PC, and is where the USB devices are physically located.

    My NoMachine server is on a Windows 10 VM hosted on a Proxmox server, and is where the software for the device is installed.

    When I forward the device to the virtual machine, it is detected and visible in Device Manager. However, it is not detected by software. I have tested multiple devices and multiple programs from various manufacturers with the exact same results: Windows sees it, software does not.


    If anyone has any ideas, I’d be happy to provide more information.



    1. Can you please tell me what kind of devices you have forwarded?

    2. Is it possible to try to forward pendrive on mouse? The devices that work without additional software.

    3. Do you have installed virtio?

    4. Can you please send me screenshots from NM GUI with forwarded device and Devices Manager of server-side.



    Hi Giorgi, sorry for the late reply. The site keeps throwing errors at me and I end up having to retype everything (time for NoMachine to get a new web admin).

    1. I am testing the USB forwarding with a DJ mixer and a Garmin GPS

    2. Pendrive works, mouse does not function when forwarded

    3. Yes, but Windows 10 VirtIO drivers are installed

    4. Attached two screenshots



    The fact that Pendrive forwarding works means that the USB forwarding module of the NoMachine is installed well, with all dependency components.

    And as well as that, you can see forwarded devices in the Windows Device Manager, so this shows that it’s well connected to the remote machine.

    One of the reasons why it’s not being detected by the software┬áis maybe the device drivers are not installed properly on the machine where you forward your device.

    Few more questions.

    1. Can you check whether connecting your device physically to the server (not client) and forwarding the device from the server host to the VM running on the same host actually works?

    2. Are your two machines located in one local network? What’s the ping time between them? In some hi-traffic devices timing of the network becomes very critical.

    3. There are two optical mouses in your window, have you tried to forward the other one? Did it work?

    4. Is there any chance to forward device to another Windows 10 PC (NOT VM), with installed software?

    Another recommendation it’s better to forward one device at a time (especially hi-traffic device) and if it fails (with a red sign near the device) restart both machines.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.