Frame buffer on server not started: nxFrameBuffer aborted

Forum / NoMachine for Linux / Frame buffer on server not started: nxFrameBuffer aborted

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #12838


    I just installed the latest NX free software (5.1.54) on my Linux computer running Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-100-generic x86_64) with default desktop Unity installed.

    From my MacBookPro, connecting to the Linux fails with the above error. Discovery on LAN etc works perfectly. I firstly tried to get NX create a virtual desktop (which failed with another exception as well), after which I logged in the Ubuntu computer to try to recycle the session via NX. This gave the error above.

    I attached a zip with the logs that I was able to create using the client’s functionality ‘Save logs’.

    What is going wrong? How to solve the issue? Thanks!





    It seems that the server has every session type disabled and this causes the connection problems. Please edit the server configuration file:


    and make sure that key


    is uncommented and it includes both nxvfb and physical-desktop entries.

    For example working key for free version should look like this:

    AvailableSessionTypes nxvfb,physical-desktop

    If modification is required, please restart nxserver (as administrator user)

    /etc/NX/nxserver –restart

    and try connecting again.

    If this does not help, please enable debug and submit logs.
    Instructions are available here:

    Please include the configuration files:

    Send them on to forum[at]nomachine[dot]com making sure to reference your topic.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.