Frozen virtual desktop when WebRTC is enabled in WebPlayer

Forum / NoMachine Terminal Server Products / Frozen virtual desktop when WebRTC is enabled in WebPlayer

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #18862


    Looking for some advice. Evaluating NM Workstation. version 6.2.4. Host: Ubuntu 16.04 virtual machine running with NAT network configuration.

    When running a virtual desktop via webplayer in Classic mode, everything is fine. I am aiming to get sound working and understand the only way to do this via WebPlayer is by using WebRTC.

    When I enable WebRTC via server.cfg and restart (using public the NM web session establishes OK and loads the virtual desktop. I get sound for about 5seconds-3mins after which the desktop screen will freeze indefinitely (the browser window is still responsive i.e. i can still get to the “tear menu” in the top right).

    I have tried other public STUN servers, same issue. I have tried with my own install of a Coturn server installed on the Virtualbox host which has an external IP, same issue (although I am not 100% familiar with this product so take that just for info only). Sound works fine when I connect via NoMachine Full Client.

    I guess the issue could be sound or video related (i get an H.264 error in my connection log but I am assuming this is “information only” as I dont think the codecs ship with the eval version of NM Workstation???)

    Am i missing something basic here or are there any useful suggestions??? I know there’s alot of variables here – my suspicion is the problem might be NAT related although why would i get sound working for a few random seconds/minutes?

    Here’s an example Session Log, connected at 13:40, froze about 13:43:

    Session: Starting session at Tue Jul 3 13:40:11 2018.
    Info: Agent running with pid 14203.
    Info: Display running with pid 14230.
    Info: Slave server running with pid 14229.
    Info: Listening to slave connections on port 12002.
    Info: Audio server started with pid 14231.
    Info: Audio client started with pid 14232.
    Info: Display server started with pid 14233.
    Session: Session started at Tue Jul 3 13:40:11 2018.
    Info: Using SSE3 for screen analysis.
    Info: Encoder running with pid 14267.
    Info: Updater running with pid 14659.
    Warning: Can’t load H.264 codec library.
    Warning: Child process 14660 exited with code 2, ‘No such file or directory’.
    Info: Audio server for 07FE7EB9CC70473C62EBA048FCF1C0FD connected on Tue Jul 3 13:40:13 2018.
    Audio Pointers are set.
    Info: Display server for 07FE7EB9CC70473C62EBA048FCF1C0FD connected on Tue Jul 3 13:40:13 2018.
    14203 14659 13:40:13 750.781 DisplayEncoder/DisplayEncoder: ERROR! Failed to encode H.264 frame.
    Info: Using Vp8 software encoder.
    Info: Using screen size 1299×639.

    Info: Audio reader running with pid 14853.


    I have been continuing my research into this frozen screen when WebRTC is enabled.

    I built a fresh install of NM Workstation on a server (in a hosting datacenter) directly connected to the internet so ruling out NAT issues completely.

    I load up a classic (non WebRTC) web session virtual desktop and run a YouTube video (without sound) without issue.

    Then I enabled WebRTC (using, restart nxserver. Connect to a virtual desktop. load up a YouTube video and after a minute or so, the desktop freezes again.

    Is this a performance issue when using WebRTC? Can you guys recreate a working webplayer/webrtc virtual desktop and run video for an extended period without freezing?

    Any optimization suggestions?


    Hello. Thank you for reporting your problem to us. We’re working on a fix. I tried to reproduce your problem and found the same with Firefox browser. If I use Opera, Chrome it works fine. Could you try to do the same with those browsers? Thank you.


    Thank you so much for looking into this.

    Freezing Issue replicated on:
    Firefox 61.0.1 (64-bit)
    Chrome Version 67.0.3396.99 (Official Build) (64-bit)
    Opera 54.0.2952.54

    Connection using VP8 (WebRTC), audio Opus 48khz stereo

    I am glad you are able to replicate this problem – not wanting to confuse this thread with too many variables but i have carried out a fair bit of testing and replicated freezing with various STUN providers (public, local and third party), with/without h264 encoding (compiled from your web download library), different linux distros, NM Enterprise Desktop and NM Workstation products etc (all this testing was from Firefox though). I also experience the freeze outside of youtube videos etc, ie normal browsing or OS use will eventually result in a freeze. Are you able to provide an ETA for your fix or a ticket number for me to track?


    Hi dc2008, there’s a Trouble Report here:

    You can sign up to receive a notification from us by clicking “notify me” 🙂



    Thanks for the TR link – it doesn’t appear to relate directly to my issue but I will assume you have general issues with WebRTC connections via web connections and that my experience is another symptom of your known issue.

    I notice the TR has a “minor” impact status. We are evaluating NoMachine to provide clientless browser access to Linux desktops – currently my experience is that if I enable WebRTC, the connection dies after 30 seconds-5 minutes so effectively unusable in a production environment. My understanding is that enabling WebRTC is key to testing other performance and feature tweaks i.e. sound/H264 compression, etc.

    Given this experience is there a chance this problem could be reclassified with an impact of greater than “minor”? Or perhaps an ETA or the chance to test a beta release?

    Appreciate your assistance.



    Hello dc2008,

    We are working on a fix to your problem, and we changed the severity of the TR to “serious”.

    As this TR does not correspond exactly to your issue, we will open a new TR that corresponds to your issue.



    Please use this TR link to check when a patch is available:

    Frozen screen when connecting via WebRTC session through TURN server

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as closed, you can't post.