Game controller not forwarded to games in Google VM

Forum / NoMachine for Linux / Game controller not forwarded to games in Google VM

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #47195


    I am testing games on a Google Virtual Machine, and I have forwarded the game controller, but the games do not detect it in the Google VM. The game controller is detected by the kernel and can be tested with Joystick API (/dev/input/js0) based software like jstest-gtk, but programs like Steam or emulators like Mupen64plus do not detect it.

    I am using a Google VM with Linux Ubuntu 22.04 and Xfce, and also a local Linux Ubuntu 22.04 with Xfce, NoMachine 8.11.3_4_amd64 free version, a wired Xbox360 game controller, default xpad module detected, and I have also tried using the xboxdrv driver with no changes.

    Thank you.


    Antonio Ruiz


    I have identified the issue. The user needs to be in the input group for SDL input-based games. Additionally, mupen64plus has a configuration file for game controllers.


    Interesting. So NoMachine is now working in your set-up?


    I have encountered some lag, possibly because of using software acceleration. The free game promotion doesn’t support adding GPUs, affecting the performance of older 3D games like the native Linux game Portal and emulated DirectX games such as Dead Space. However, older or simpler games can still run quite well, depending on the CPU chosen.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.