GLX doesn’t work (NoMachine Workstation, Debian Sid)

Forum / NoMachine Terminal Server Products / GLX doesn’t work (NoMachine Workstation, Debian Sid)

Tagged: , , ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #15910


    I am currently evaluating NoMachine Workstation on Debian Sid (NoMachine-Workstation 5.3.12-11). I am using i3 (no desktop environment) in a virtual session on a completely headless server (it doesn’t even have installed).

    I have recently upgraded my system and since then it appears there are issues running applications that rely on GLX.

    For example, if I try to run the QT-based ReText Markdown editor:

    $ retext
    Could not initialize GLX
    $ glxgears
    Error: couldn't get an RGB, Double-buffered visual
    $ glxinfo
    name of display: :1001
    Error: couldn't find RGB GLX visual or fbconfig
    name of display: :1001
    Error: couldn't find RGB GLX visual or fbconfig
    $ ldd /usr/bin/glxinfo (0x00007fffe48c0000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3d0c24000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3d09b5000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3d0729000) => /lib/x86_64-linux-gnu/ (0x00007ff3d0425000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3d00e5000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3cfed3000) => /lib/x86_64-linux-gnu/ (0x00007ff3cfb36000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3cf7b7000) => /lib/x86_64-linux-gnu/ (0x00007ff3cf5a0000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3cf36f000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3cf0b9000) => /lib/x86_64-linux-gnu/ (0x00007ff3ceeb5000) => /lib/x86_64-linux-gnu/ (0x00007ff3cec98000)
    	/lib64/ (0x00007ff3d10c5000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3cea70000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3ce86c000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff3ce666000) => /lib/x86_64-linux-gnu/ (0x00007ff3ce451000) => /lib/x86_64-linux-gnu/ (0x00007ff3ce249000)

    Packages with “glx” in the name that are installed on the system: libglx-mesa0 (17.2.1-2) libglx0 (0.2.999+git20170802-5) libxcb-glx0 (1.12-1)

    I also attached the output of the xdpyinfo command, which does mention the GLX extension.

    Note that I am *not* looking to enable hardware acceleration using VirtualGL or anything like that. I am fine with basic software-based rendering. I just want it to work.


    I managed to find a workaround.

    I noticed that during my Debian system upgrade the mesa packages were updated from 17.1.5-1 to 17.2.1-2. If I roll them back to 17.1.5-1 then everything works again.

    This leads me to conclude that the changes between mesa 17.1.5 and mesa 17.2.1 are breaking GLX on NoMachine Workstation virtual sessions.


    Thanks for reporting. Debian sid provides the latest available libraries, so it is possible. By the way we are going to investigate in order to address this issue on our side.


    The system requires to be available. This should be a symlink to

    Took me quite a while to figure out, but I now have GLX on virtual NoMachine desktops

    This is what you need to do:

    Make sure you have the package libglx-mesa0 installed

    cd /usr/lib/x86_64-linux-gnu/

    ln -s



    FerdH, thanks for the tip.
    By the way, I’ve just updated a Sid system and that symlink looks fixed now.
    glxgears runs fine.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.