“Grab the keyboard input” does not work anymore

Forum / NoMachine for Linux / “Grab the keyboard input” does not work anymore

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #48651
    maxim-nomachine
    Participant

    It sends such shortcuts like Alt+F4 to local host and to remote host. Previously it was possible to send it to remote one only.

    I guess it is related in some way to KDE updates, but maybe I am wrong, I am not able to dissect it.

    Operating System: openSUSE Tumbleweed 20240625
    KDE Plasma Version: 6.1.0
    KDE Frameworks Version: 6.3.0
    Qt Version: 6.7.2
    Kernel Version: 6.9.6-1-default (64-bit)
    Graphics Platform: X11

    NXPLAYER – Version 8.11.3

     

    #48653
    Britgirl
    Keymaster

    What is the OS on the nxplayer side?

    Did you try a reboot on the openSUSE side? Is the issue just the Alt F4 key or other Alt+ combinations? Are other keys affected?Please describe the steps you take to reproduce the behaviour.

    #48655
    olaf
    Participant

    I also noticed similar issue after KDE Plasma was updated to 6.1.0 on client-side computer.  Shortcut keys are now captured by local computer running NoMachine client instead of being sent over to remote computer.

    Thank you!

    #48654
    maxim-nomachine
    Participant

    What is the OS on the nxplayer side?

    The version provided is nxplayer side. Version of the remote one is OpenSUSE Leap 15.6.

    Did you try a reboot on the openSUSE side?

    Yes, both sides. All updates are installed, systems are rebooted.

    Is the issue just the Alt F4 key or other Alt+ combinations?

    I assigned custom shortcut Meta+R in System Settings | Shortcuts

    The app executed in both systems: local and remote (if grab is enabled, if not then only local system).

    Please describe the steps you take to reproduce the behaviour.

    Nothing specific most likely it started to happen after update of local side. Maybe some incompatibility with fresh rolling libs.

    I just tested another environment and it works fine:

    Operating System: openSUSE Tumbleweed 20240621
    KDE Plasma Version: 6.0.5
    KDE Frameworks Version: 6.3.0
    Qt Version: 6.7.1
    Kernel Version: 6.9.5-1-default (64-bit)
    Graphics Platform: X11

    After updating to latest version (zypper dup) it has the same grab input issue. Updated system the same as originally tested one:

    Operating System: openSUSE Tumbleweed 20240625
    KDE Plasma Version: 6.1.0
    KDE Frameworks Version: 6.3.0
    Qt Version: 6.7.2
    Kernel Version: 6.9.6-1-default (64-bit)
    Graphics Platform: X11

    #48658
    Britgirl
    Keymaster

    Can you start the player from a terminal instead like this?
    /usr/NX/bin/nxplayer --activegrab

    Btw, Check what’s configured in your nxs file because this setting will override your global setting (configured in Player). You can check what’s in the .nxs file by locating it in the directory defined in the ‘Connections and recordings’ field from the Settings -> Player -> Folders panel of the User Interface.

    #48659
    maxim-nomachine
    Participant

    Can you start the player from a terminal instead like this?
    /usr/NX/bin/nxplayer –activegrab

    Check what’s configured in your nxs file because this setting will override your global setting (configured in Player). You can check what’s in the .nxs file by locating it in the directory defined in the ‘Connections and recordings’ field from the Settings -> Player -> Folders panel of the User Interface.

    What is the reason to do that?

    I wrote:

    I assigned custom shortcut Meta+R in System Settings | Shortcuts The app executed in both systems: local and remote (if grab is enabled, if not then only local system).

    Obviously it says that I have the way to confirm if grab was really enabled or not.

    /usr/NX/bin/nxplayer –activegrab

    It was tested before I created this issue. It does not have any effect.

    #48662
    Britgirl
    Keymaster

    It was tested before I created this issue. It does not have any effect.

    I see, I didn’t see you mention that earlier. Anyway, we are still unable to reproduce the problem with grabbing the keyboard on Plasme 6. But we did find a bug report on the KDE bugzilla. It seems very like your issue.

    https://bugs.kde.org/show_bug.cgi?id=489113

    For now, we suggest to downgrade to the environment that you said is working for you and wait for KDE to release a fix.

    #48664
    maxim-nomachine
    Participant

    OK, I will check with KDE if you think nothing should be made on NoMachine side.

    Just one question. Should grab work in Wayland session?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.