Hang after password entered

Forum / NoMachine for Linux / Hang after password entered


Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #39111

    I run Ubuntu, currently Jammy Jellyfish, Gnome desktop. I have NoMachine 7.10.1 installed on two machines. One machine (desktop) acts as NM Client. The other (server) acts as NM Server. The server is NOT headless, and usually no user is logged on there.

    When I start the NM Client to connect to the Server, I see the remote login screen, click the user, enter the password and … That’s it. The login doesn’t appear to proceed, and I never see the desktop?


    Hi, when you log in, does the spinning wheel show in the NoMachine window. Do you get past this stage?

    I never see the desktop

    Do you see a black screen? Do you see a message of any kind?

    Please submit a screenshot of what you see from log in to the final stage where the login doesn’t proceed.

    We have reproduce something similar and there is a Trouble Report open: https://kb.nomachine.com/TR07S10316.


    Try pressing [Ctrl] [Alt] and [F1] to switch to the main TTY terminal. This will take you to TTY0, enter your login name and press Enter. You will be prompted for a password-Enter it (it is a blind type because the warning does not show the password. Run sudo apt-get autoclean –sudo apt-get autoremowe. Run the following command to clear the package cache. Update: -sudo apt-update your system using the following command-sudo apt-get upgrade When you are done, you can use the following command to return to the GUI-chvt 7

    Hope this helps.



    1) The login screen doesn’t go away. See screenshot.

    2) No messages of any sort.

    3) The trouble report TR07S10316 does not apply. The login never proceeds. (https://kb.nomachine.com/TR07S10316)

    4) I’ve attached a screenshot. (I’ve blurred out the login account, which is probably overcautious.)

    5) I forgot to say that I’m using the free version.


    Run sudo apt-get autoclean –sudo apt-get autoremowe. Run the following command to clear the package cache. Update: -sudo apt-update your system using the following command-sudo apt-get upgrade

    Updating the server-side installation might help.

    You’d have to try Enkidu. Could you also tell us whether logging in to the desktop first (on the local server side) and then starting your NoMachine session makes a difference? This would allow us to narrow down the investigation.

    If you can still reproduce the behaviour, we will need logs from the Ubuntu server. Enable logs following the instructions here: https://kb.nomachine.com/DT11R00182, reproduce the problem, then gather the logs from the server. Send directly to forums[at]nomachine[dot]com.


    Thanks Britgirl. I will try to get the logs.

    In the meantime, I’ve discovered that if I go to the ‘server’ and login there, when I come back the login has completed.

    I opened a terminal session on the server, and the NX session on the ‘client’ does not have that terminal session.

    Does that help?


    I do know what the apt commands mean but I’m not sure what they are supposed to achieve, in the context of my problem. However I carried them out, as suggested, with no change.

    Incidentally, on my Ubuntu 22.04 system [Ctrl][Alt][F1] appears to restart X. However I can use other VTs from 3 on up. I didn’t need the VT as I can ssh into the ‘server’ system.

    So, I did a command line shutdown/startup of the NoMachine server, (/usr/NX/bin/nzserver –shutdown/startup), logged into the desktop of the server machine, then connected to server from the client machine, and it worked.

    A little later I tried again and it didn’t work! The remote screen on the server machine was locked and as soon as I unlocked it, the NoMachine client connection worked. So it appears that the remote machine must be logged in and not locked before I can connect from the remote machine.




    Hi, your last explanation clarifies things a lot 🙂 It’s not a NoMachine issue, it’s a bug in Gnome and is reported on other forums also with other remote desktop tools. You can unlock it by staring starting an ssh terminal to the host as the same username and run the following:

    loginctl unlock-sessions

    We also suggest to disable automatic screen lock on that machine.


    Wow! I had a hunt through the Gnome Issues list and that’s… messy.

    Thanks for the solution – “loginctl unlock-sessions” works fine, thanks. It does unlock the physical desktop too, but that’s OK for my purposes. I think that I could use “loginctl unlock-session <session>” according to the man page, but I’ve not investigated.

    I could disable the automatic screen lock (through “Settings”, I found) , but I’m not sure that I want the screen to be unlocked all the time.

    Thanks again, Britgirl!

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.