Help changing resolution on connection

Forum / NoMachine for Linux / Help changing resolution on connection

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #39727

    In the past I used NoMachine to connect to a machine that uses a 3840×1200 monitor with no problem, I could change the resolution to 1920×1080 after connection. Now I changed that machine but not the monitor, I installed a new OS (Majaro Linux with KDE / Wayland instead of Manjaro Linux with Cinnamon that I used previously) and now I’m totally unable to change the resolution like before.

    Is there any way I can get the resolution changed? I don’t care it is the same physical session that is connected to the monitor, or a different session, but I need it to change resolution to 1920×1080.


    I tested to change the PhysicalDisplay value as explained in the ArchLinux wiki to get a separate session, with:

    PhysicalDisplays :10

    This way NoMachine display settings allows me to change resolution, but no desktop environment is loaded, just mouse pointer and black background. I know it is working because a NoMachine notification for my login appears and if I click in it it opens OK. Any idea why it may not be loading the desktop?


    Changing in node.cfg the DefaultDesktopCommand as indicated on the Arch wiki for headless servers give me a X session on my computer, but it seems pretty random (I have to restart NoMachine several times for it to work) and I have no audio on the server side (but it allows me to stream audio through NoMachine).

    So, finding a solution for the initial problem (being able to change NoMachine resolution on a “normal” connection) is still desirable.


    There was a similar problem with Arch and Pam a while back (desktop not showing) and there was a solution. Arch is not amongst our supported Linux, but we will do our best to provide as much help as possible to allow users to install and use NoMachine. This is the earlier topic:

    Anyway, we checked on the fly to see if something had changed since then, which it has.

    1. Create a backup of nx PAM configuration (sudo cp -a /etc/pam.d/nx /etc/pam.d/nx.original). Then change /etc/pam.d/nx in this way:

    auth include system-login
    account include system-login
    password include system-login
    session include system-login

    2. Change DefaultDesktopCommand in /usr/NX/etc/node.cfg in order to have this on KDE case:

    DefaultDesktopCommand "/usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/startplasma-x11"

    3. Stop display manager:
    sudo systemctl stop display-manager

    4. Restart NoMachine:
    sudo /etc/NX/nxserver --restart

    This worked for us.


    Thanks for replying.

    I already tried that after a lot of reading on the Arch wiki and this forum, but there is always a caveat, if I change the pam.d file I totally lose sound, if I don’t I don’t have permissions for system update app, etc…

    I went back to “normal” NoMachine connection, as I can’t change resolution I have to resize window and it looks ugly as hell but everything else works (sound either on physical hardware or through NoMachine, permissions for apps, …).


    I’d also like to add a note about resolution since this is what the topic was originally about. Arch and PAM problems aside 🙂 the resolution of the physical desktop depends directly on the system settings and what your graphics card supports and not NoMachine. This means that when you are connecting to the physical display, NoMachine can show you the display according to the resolution sizes available with the graphics card installed and these will show in the Display settings of the Connection Menu. In a physical desktop session, the resolution on the client cannot be changed to one that is not supported by the remote GPU. More about this is explained here:

    Some tips about resize and scaling options for NoMachine remote desktop software


    That is the strange part: I used the same Operating System, Kernel and GPU drivers before formatting, the only thing that have changed is the desktop environment I use, but in the past the NoMachine client configuration let me choose several different resolutions and now it doesn’t.

    Of course, something more must have changed to cause this behaviour, but I can’t pinpoint what…


    Out of interest, are you able to physically set the resolution as you want it in KDE? I.e not by connecting with NoMachine?

    Nothing has changed in NoMachine that would change how resolution is handled.

    NoMachine client configuration let me choose several different resolutions and now it doesn’t.

    Were you maybe using NoMachine Workstation in the past? This would allow different resolutions (being virtual NoMachine desktops). A note from the article I mentioned earlier: The supported resolution for virtual NoMachine desktop sessions (Terminal Server for Linux products) doesn’t depend on the remote hardware and thus the remote screen can be resized to whichever resolution is supported by the user’s local monitor.


    ” Out of interest, are you able to physically set the resolution as you want it in KDE? I.e not by connecting with NoMachine?”

    Yes (screenshot attached).

    “Were you maybe using NoMachine Workstation in the past?”

    I surely wasn’t. I’m using the exact same client, no changes on that computer at all, and for the server I installed the same package that I used before formatting from Arch AUR repositories.


    Hello madmalkav,

    Unfortunately we are still unable to understand why it doesn’t work. In order to invesigate further, can you please send us a new set of logs (server and client) to forum[at]nomachine[dot]com, making sure to reference the topic in subject ?

    If needed, here’s the procedure to collect NoMachine logs:


    Hi Billbotine,

    I changed the workflow, instead of connecting from Windows to Linux, I’m connecting from the Linux machine to Windows with RDP and that way I can work with audio from both computers, so I consider this solved for me.

Viewing 11 posts - 1 through 11 (of 11 total)

This topic was marked as solved, you can't post.