High CPU usage in Catalina

Forum / NoMachine for Mac / High CPU usage in Catalina

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #29101

    Hi guys,

    I’m using NoMachine on a pretty powerful Mac (iMac 5K, 4GHz i7, Catalina) to connect to a nearby laptop running Ubuntu.

    This all works swimmingly, except that NoMachine on the Mac will often use a bizarre amount of CPU power, rarely under 60% and often around 150%.

    This wouldn’t bother me so much but the CPU usage is enough to make the fan in the iMac spin up and down as I’m using NoMachine, which is pretty annoying.

    I have no idea why NoMachine is using this much CPU power. It doesn’t seem to be correlated with anything I’m doing. I tried playing a YouTube video on the laptop and NoMachine only used about 60% CPU to display the video. But when I’m in a text editor, doing essentially nothing, the CPU usage will often spike to 150%.

    And once it spikes to 150%, I can stop using it, with literally nothing going on on the screen, only 2-3 kilobytes of data being transferred between the machines, and it will keep using 150% of a CPU core for a good 10-20 seconds before it quiets back down.

    I mean, what is it doing? Why does it need that much CPU power to do literally nothing?

    Thanks in advance for any help/suggestions people can offer. I appreciate it.

    Oh–this is for recent versions of NoMachine (downloaded and installed in the last week), Catalina on MacOS, Ubuntu 20 on the laptop, fully updated OSs on both, connecting to the physical display on the laptop. Ubuntu is running the default window manager for version 20 which I believe is Gnome.


    Hi. The behaviour is unexpected and we could not reproduce it so far, so I’d be grateful if you can help to debug it.
    What is the text editor causing the CPU spikes? Did you notice the same with other remote apps?
    It would be great if you can dump some information while the CPU is high, by running the following commands in Terminal:
    ps -M $(pgrep nxplayer) > ~/Desktop/threads.log
    sample $(pgrep nxplayer) -file ~/Desktop/sample.log (wait 10 seconds for the sampling to complete)
    Send the files threads.log and sample.log on your Desktop to forum[at]nomachinec[dot]com.
    Thank you!


    Thank you so much for looking into this. I have sent in several log files as requested. Please let me know if you don’t get the email(s). I believe there was a typo in the email you posted (should be nomachine instead of nomachinec). I sent the email to both addresses just to make sure. Let me know if there are any issues!


    We received the logs 🙂


    Hi. Please open Display settings in session menu and check the box “Disable multi-pass display encoding”. Do you see any improvements?


    Hi, yes, disabling that feature (multi-pass display encoding) reduced the CPU utilization enormously, that’s quite good!

    It also reduced the image quality very noticeably for my purposes. (Mostly using command line terminals and text editors.) So that’s not as good.

    Thank you for the suggestion. I’m crossing my fingers that in the future there might be a way to hit a better balance between CPU utilization and image quality.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.