How long does a UPnP port take to open?

Forum / NoMachine for Windows / How long does a UPnP port take to open?


  • This topic has 3 replies, 2 voices, and was last updated 8 years ago by irek.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #11597

    I’m just starting out with NoMachine Free 5.1.26 and done some tests of my own and seems to work okay.

    So I asked a relative to install it on their PC so I can offer them remote support of their Windows 10 desktop.

    They installed and all seemed good with an external IP and port created with uPnP which they sent to me for my reference (I didn’t test connecting to them at the time).

    A few days later they asked me for some help but I couldn’t connect with the IP/Port they gave me.  At first I thought maybe the external IP changed but when they checked “NoMachine Service”, they said there was no external IP/port listed like when it was first installed, only local IP.

    I had them restart the service, reboot, restart router, etc and no change, so they left the host computer on for me and I came back maybe 30 minutes later after a break to try again.  Magically the original IP/port combo connection worked.

    This made me wonder if it is normal to have to wait a minimum amount of time for a gateway IP/port to be created on the host side after the service starts?  I didn’t think this would be very long, since the IP/port was available pretty much immediately on installation.  But seemingly after powering off everything (including router) it goes missing, for an unknown amount of time (at the time of writing this).

    Its a new Skylake CPU, so not slow to boot or anything.  It’s even possible the PC is booting before the router has finished getting a DSL line, so maybe NoMachine has to periodically retry to get a gateway port through UPnP?

    I don’t mind if it takes a while, just want to know how long I should wait after booting, or if there is a configurable retry setting on the host service?

    Any thoughts?


    NoMachine Server refreshes UPnP ports every 5 minutes, so in the case where NoMachine Server started before the router, you will need to wait until the router finishes boot up, and then about 5 minutes.

    However there is a way to “force” NoMachine Server to refresh ports by hand. Open a console as Administrator, go to the installation directory of NoMachine Server and run command

    nxserver --upnpmap


    Hi irek

    Thanks for this very clear and concise reply.

    Seems at the very worst I would have to wait 10 minutes which is acceptable to me.  I will test it actually happens consistently. 🙂

    Out of curiosity, is 5 minutes refresh configurable?


    I miswrote the time need, it should have been about 9 minutes.

    As for being able to change the time used to refresh port mapping, unfortunately it’s not possible.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.