How to get SSO to work

Forum / NoMachine for Windows / How to get SSO to work

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4911
    clocatel
    Participant

    Hi,

    we didn’t succed to make NoMachine SSO work. ¬†We have several CentOS 6.4/GNOME (desktop, virtual on vSphere) integrated in Active Directory. When we launch a NoMachine remote session on these desktop, NoMachine ask us for login. It works, then it opens remote screen. But it doesn’t open the session. I need to logon again with the gnome login screen.

    So, to open a session on these CentOS workstations, I need to login twice.

    We read all the documentation but we didn’t understand exactly what to do in our case. We used free version, then enterprise (trial). Same behaviour. We use NX protocol, so i don’t know if all help pages about SSH are usefull (tried to change sshd, PAM).

    Does someone have the same configuration (AD integration, NX protocol/4000) and manage SSO ? If yes, what is your exact configuration ?

    NoMachine Free or Entreprise 4.2.x and 4.3.x (tried several versions)

    Local desktop : Windows 7 and Windows 8.

    Thank you.

    #5141
    Britgirl
    Keymaster

    From what you write it seems that you are connecting to a physical desktop session. Did you try Enterprise Desktop or Enterprise Server? The latter offers the virtual desktop functionality (as do Workstation, Terminal Server, Cloud Server) which is what you should be using.

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.