How to grab keyboard inputs in Android

Forum / NoMachine for Mobile / How to grab keyboard inputs in Android

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #37882

    Hello everyone!

    So, basically I am using an instance in GCP and I am accessing it using NoMachine for the GUI experience (the host is Ubuntu 21.10).

    It works wonders when using my laptop. The problem is when I try to use my Samsung tab s7.

    Either in the regular android-tab format or in Dex mode I cannot grab the attached bluetooth keyboard inputs to be send straight into the host, and because of that I am experiencing a very limited usage of the system, since I do most of my navigation using shortcuts and also because they are expected to be used in Ubuntu (or most linux GUIs), like accessing the workspaces pressing the win/command key.

    In the example of win/command key, when it is pressed, instead of the input being sent to the host (to open the workspaces interface of gnome) it is instead grabbed by the Android system to launch the voice assistant.

    I have searched around the forum and on internet, as well in NoMachine’s configs, but so far haven’t found a solution to it.

    I have also tried disabling android shortcuts, but in that scenario the key or the shortcurt just becomes dead, doing nothing either in Android or in the host.

    Has anyone got a solution to that issue? I might be blind hahaha but haven’t really found anything.

    Thank you everyone for your assistance and time!



    This isn’t possible on Android AFAWK. As of now there is no way to grab the input of an external keyboard on Android in order to avoid some keys from being captured by the system. There are hacks out there but nothing official.  If this ever becomes possible, we’ll certainly update the application to make use of it. NoMachine allows shortcuts which are not being captured by the system. Until then, for certain key combos, users should use the virtual NoMachine extended keyboard.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.