How To Install & Configure NoMachine on Rocky Linux 9

Forum / NoMachine for Linux / How To Install & Configure NoMachine on Rocky Linux 9

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #46419
    bryan3301
    Participant

    I had NoMachine working on Rocky Linux 9; however, I was unable to resize the display. I believe this was due to the local display, so, I changed to boot into console instead of GUI (sudo systemctl set-default multi-user.target). This allowed NoMachine to use it’s own X server and I was able to resize.

    I then tried to get sound working (it was working until I made the change above). I followed the steps here (https://kb.nomachine.com/AR07T01168) and here (https://forum.nomachine.com/topic/unable-to-get-audio-working-through-pulseaudio-in-almalinux-9).

    Now, when trying to connect via NoMachine, I receive an error it cannot connect to a gnome-session. I also no longer am able to get the server’s console to boot to the GUI (even after setting  sudo systemctl graphical.target).

    I am not sure where to start. I am hoping someone can point me in the right direction, or even better, supply a good “how to” on making everything work on Rocky Linux 9?

    #46438
    bryan3301
    Participant

    UPDATE: Problem Resolved & NoMachine Fully Operational

    Repair GUI
    Here is how I repaired the GUI and got it working again:

    sudo dnf remove -y pulseaudio
    sudo dnf group install “Server with GUI”
    sudo systemctl set-default multi-user.target
    sudo reboot

    Enable Audio
    After the above, the GUI was working, I then proceeded to make audio work.

    Configure pulseaudio to work with PipeWire (https://kb.nomachine.com/AR07T01168)
    sudo dnf install pulseaudio –allowerasing
    sudo dnf install pulseaudio-utils
    sudo /usr/NX/scripts/setup/nxnode –audiosetup

    Configure audio (https://forum.nomachine.com/topic/centos-nomachine-server-no-sound)
    sudo /usr/NX/bin/nxnode –audiosetup /etc/pulse
    sudo /etc/NX/nxserver –restart
    sudo reboot

    For those what want the full process, start-to-finish, here you go:

    Download NoMachine 

    link 

    Install NoMachine via local RPM 

    sudo rpm -i nomachine_8.10.1_1_x86_64.rpm 

    Create firewall service entry 

    sudo cat << EOF > /etc/firewalld/services/nomachine.xml 

     

        nomachine 

        NoMachine 

        tcp” port=”4000″/> 

     

    EOF 

    Configure firewalld 

    sudo firewall-cmd –permanent –zone=trusted –add-service=nomachine 

    sudo firewall-cmd –permanent –zone=home –add-service=nomachine 

    sudo firewall-cmd –permanent –zone=internal –add-service=nomachine 

    sudo firewall-cmd –permanent –zone=work –add-service=nomachine 

    sudo firewall-cmd –reload 

    Change to console boot (disable GUI boot). This is so the NoMachine X server is used, which will properly resize the remote display as the client window is resized. 

    sudo systemctl set-default multi-user.target 

    Configure pulseaudio to work with PipeWire (https://kb.nomachine.com/AR07T01168

    sudo dnf install pulseaudio –allowerasing 

    sudo dnf install pulseaudio-utils 

    sudo /usr/NX/scripts/setup/nxnode –audiosetup 

    Configure audio (https://forum.nomachine.com/topic/centos-nomachine-server-no-sound

    sudo /usr/NX/bin/nxnode –audiosetup /etc/pulse 

    sudo /etc/NX/nxserver –restart 

    Reboot 

    #46450
    Britgirl
    Participant

    Hi, glad to know a reinstall fixed the problem and you found the article in our knowledge base about using Pipewire 🙂

    A tip about Gnome sessions and not being able to connect, if you come across it again, send the output of sudo grep DefaultDesktopCommand /usr/NX/etc/node.cfg

    We checked on stock Rocky Linux 9 and didn’t have any issues. That command shows: DefaultDesktopCommand "/bin/dbus-run-session gnome-session --session=gnome" and works fine.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.