How to remove NoMachine NX server?

Forum / NoMachine for Linux / How to remove NoMachine NX server?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #23157

    I get this error message during boot:

    Failed to start NoMachine Server daemon
    See ‘systemctl status nxserver.service’ for details.

    But if I give that command in a shell, I get:

    $ systemctl status nxserver.service
    Unit nxserver.service could not be found.

    I remember that I tried to install NoMachine months ago. I guess I made some mistake when uninstalling it.

    I tried to search for “nxserver” in nautilus, and I get no result. But if I search “nx” I find a lot of results, one being a “NX” folder in /usr/ path. I guess this folder gets deleted if nxserver is correctly uninstalled. Still I’m not really sure how to do that.

    I do I get rid of such boot error message? How do I completely uninstall such nxserver?

    I use Fedora 30.


    Hello Amivaleo

    Looks like really something went wrong during uninstallation. I think that the quickest way to solve your problem is to install again and uninstall NoMachine following the regular procedure. Please follow these steps:

    1) remove leftover dirs:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    2) install again:

    sudo rpm -i nomachine_6.7.6_11_x86_64.rpm

    3) uninstall:

    sudo rpm -e nomachine



    I’ve tried your suggestion. After a reboot, I still get the same errors in /var/log/boot.log. 😢



    I assume, that you have now uninstalled NoMachine.
    Please run this commands and preserve output of them:

    sudo systemctl stop nxserver.service
    sudo systemctl disable nxserver.service
    sudo rm /etc/systemd/system/nxserver.service
    sudo rm /usr/lib/systemd/system/nxserver.service
    sudo rm /etc/init.d/nxserver.service
    sudo rm /etc/init.d/nxserver
    sudo systemctl reset-failed nxserver.service

    After executed this commands if you still get the same error, please
    show us the commands output.


    I tried to mv boot.log to a backup file and, after a reboot, I didn’t have any failure. 🤔

    So maybe the previous hint worked fine… Or maybe that boot.log is really old. I assumed that it got overwritten at any new boot event.

    I can flag this as “solved” then.

    Thank you for your help! 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.