HTTP proxy with password authentication

Forum / NoMachine for Linux / HTTP proxy with password authentication

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #38885


    We have Nginx proxy server which is configured as a forward proxy. We have configured NoMachine to use a HTTP proxy without proxy authentication successfully. But when we try to configure HTTP proxy with password authentication the connection fails with error:

    Could not connect to the server. Error is 5: Input/output error

    Errors from the server log /usr/NX/var/log/nxerror.log:

    DaemonGreeter/DaemonGreeter: ERROR! Invalid client identification ‘^M’.

    Error: Invalid client identification ‘^M’.

    Warning: Connection error is 22, ‘Invalid argument’.

    and /usr/NX/var/log/nxserver.log:

    NXSERVER ERROR! Encryptor context not received.

    The proxy configuration is defined in the connection file .nxs as follows:

    NXClientSettings version=”2.0″ application=”nxclient”
    option key=”Enable HTTP proxy” value=”true”
    option key=”HTTP proxy host” value=”${PROXY_HOST}”
    option key=”HTTP proxy port” value=”${PROXY_PORT}”
    option key=”HTTP proxy password” value=”${PROXY_PASSWORD}”
    option key=”Remember HTTP proxy password” value=”true”
    option key=”HTTP proxy username” value=”${PROXY_USER}”
    option key=”Manual proxy configuration type” value=”http”
    option key=”Proxy configuration mode” value=”manual”
    option key=”Automatic proxy configuration URL” value=””
    option key=”Disable deferred updates” value=”false”
    option key=”Enable SSL encryption” value=”true”
    option key=”Disable ZLIB stream compression” value=”false”
    option key=”Enable response time optimisations” value=”false”

    I’m wondering what could be the problem?

    Nomachine server: nomachine_6.5.6_9_x86_64.rpm installation file, OS: CentOS Linux release 7.9.2009 (Core)

    Nomachine client: NoMachine Enterprise Client, version: 7.9.2, Platform: Mac OS X


    We were able to reproduce similar behaviour and have opened an internal Trouble Report for the moment. The problem appears on Squid3 configuration on newer systems (reproduced on Squid configured on Ubuntu 20.04 and Redhat 8) and can be reproduced with both NX and SSH protocols. Settings without username and password authetication work fine. The exact same Squid3 proxy with password configuration set on Ubuntu 12.04 works fine with NoMachine. The fix will be made available in the upcoming v8.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.