HW encoding with Ryzen 4800U (Windows)

Forum / NoMachine for Windows / HW encoding with Ryzen 4800U (Windows)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #43986
    cbotmk3
    Participant

    I cannot find any information on the GPU support for hardware encoding on Ryzen APUs.

    So far, GPU encoding does not work on my Ryzen 4800U HTPC (Win10) with the newest version of graphics drivers and NoMachine.

    Is there any information on how to get it working?

    #44043
    Britgirl
    Participant

    It should be working out of the box. Logs from the server would be useful. Please check the instructions here and submit to forum[at]nomachine[dot]com.

    https://kb.nomachine.com/DT07S00243

    #44062
    cbotmk3
    Participant

    Thanks for the information. I could not find anything useful in the debug logs, but eventually, I got it working:

    Enabled the checkbox “Use hardware encoding”

    AND disable: “Use acceleration for display processing”

    #44068
    cbotmk3
    Participant

    Today my problem is back 🙁

    Seems like “Use acceleration for display processing” doesn’t really matter: The problem was my desktop resolution.

    In 1080p hardware encoding is working, but not in any higher resolution. (I have to set the resolution directly in windows, setting it in the client does not help.)

    So this is probably a limitation of VCN or the GPU itself.

    Unfortunately, I can’t find any information online on what resolutions are supported for H264 encoding on my APU.

    Also rendering doesn’t “feel” any faster when using HW encoding compared to SW encoding, so I don’t really care.

    Consider this case closed 🙂

     

    #44094
    Britgirl
    Participant

    You can try activating hardware encoding for higher resolutions in the node.cfg (server side) by uncommenting the following key and setting it to:

    EncoderMode bitrate

    It is disabled for EncoderMode by default, due to the fact that the Ryzen card doesn’t support all the optimizations necessary to make it work in that mode for the highest resolutions.

    #44098
    cbotmk3
    Participant

    Oh wow, that actually worked! Thanks a lot!

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.