Information on the black screen problem

Forum / NoMachine for Linux / Information on the black screen problem

  • This topic has 6 replies, 3 voices, and was last updated 6 years ago by Mth.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #18314
    swillis0_0
    Participant

    I am using the latest free version to connect from a Linux Mint 18.3 client to two Linux Mint 18.3 servers. Everything about the two servers is as identical as I can make them. A few days ago I started getting a black screen when connecting to one of them, followed a few seconds later by disconnection.  No error message was displayed. After a bit of research and trial and error I determined that if I executed:

    /usr/NX/bin/nxserver –restart

    on the host machine I could then connect normally until the host had to be rebooted.  So I created a script to execute that command 30 seconds after startup of the machine.  The output I get from that may shed some light on the problem:

    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 162 Disabled service: nxd.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.

    Notice that it says nxnode already disabled which to me looks like the source of the problem. With my work around I’m in good shape now but I thought this might be of some interest to others.

    #18316
    Mth
    Contributor

    Hello

    It is a very strange behavior indeed. Please help us to understand this problem.

    First question, is that machine headless or runlevel 3? If not, which desktop environment
    and desktop manager is in use? Also if they are running on Xorg or Wayland.

    Second question is: on that problematic machine in

    /usr/NX/etc/server.cfg

    configuration file, do you have uncommented entry

    CreateDisplay 1

    This may cause a problem if the Xserver on the machine starts slower than NoMachine.
    If that’s the case, please check if DefaultDesktopCommand key in

    /usr/NX/etc/node.cfg

    points to a proper session command or set CreateDisplay key to 0.

    Next question is, what changes on that machine during this 30 seconds, do
    physical sessions stay in login window, or there is automatic login to user’s desktop
    enabled?

    Last thing you can try to add a key to server.cfg file:

    checkLocalSessionDelay 0

    and check if this help.

    If everything fails, please provide us with full logs. You can find instructions about debug and collecting logs here: https://www.nomachine.com/DT07M00098. Please send them to forum[at]nomachine[dot]com referring post topic in mail subject.

    /Mth

    #18332
    swillis0_0
    Participant

    First, since I made the post I’ve built another folding rig and it exhibits the same behavior and I implemented the same work around, so now I have two rigs with the issue and one without.

    First question, is that machine headless or runlevel 3? If not, which desktop environment
    and desktop manager is in use? Also if they are running on Xorg or Wayland.

    Not headless. Using the Mate desktop. I assume Xorg since I use the xorg.conf file to enable overclocking on my GPUs. When I connect successfully with nomachine or directly using a kvm I have the desktop.

    Second question is: on that problematic machine in

    /usr/NX/etc/server.cfg

    configuration file, do you have uncommented entry

    CreateDisplay 1

    steve@fah03 ~ $ grep -i CreateDisplay /usr/NX/etc/server.cfg
    #CreateDisplay 0
    # When ‘CreateDisplay’ is enabled, specify the display owner and let
    # When ‘CreateDisplay’ is enabled, specify the resolution of the new

    This may cause a problem if the Xserver on the machine starts slower than NoMachine.
    If that’s the case, please check if DefaultDesktopCommand key in

    /usr/NX/etc/node.cfg

    points to a proper session command or set CreateDisplay key to 0.

    Next question is, what changes on that machine during this 30 seconds, do
    physical sessions stay in login window, or there is automatic login to user’s desktop
    enabled?

    The 30 second delay I incorporated was just to make sure everything was started and stable. Automatic login is set up on both the problem rigs and the one that doesn’t have the issue.

    Last thing you can try to add a key to server.cfg file:

    checkLocalSessionDelay 0

    and check if this help.

    I tried that but OMG. I was able to connect with NoMachine but the desktop was all but unusable. Everything was huge and I didn’t have access to all the desktop. To make matters worse when I tried my kvm the screen was just blank. I was able to remove the line though. I’m guessing it used the motherboard video instead of the video card I’m set up to use.

    I’ll try and get you those logs

    #18373
    swillis0_0
    Participant

    The situation has gotten worse. My work around no longer works. Now I have to connect to the box using my kvm, then once I do that and disconnect the kvm I can connect using NoMachine.`

    #18427
    swillis0_0
    Participant

    Apparently I’m just not going to get any help with this.

    I’m now having the problem on three machines. The work around is to connect to the remote machine using my vpn and afterwards nomachine connects. Before I use the vpn when I try and connect using NoMachine I get the message that:

    Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?

    I select yes but then just get a black screen for a few seconds followed by disconnection. I suspect it’s a Linux problem but I was working for months and suddenly it just stopped working.

    I submitted my logs as requested but then never got any response back.

    #18432
    Britgirl
    Keymaster

    Hi, we got the logs, and we haven’t forgotten 😉

    Mth will update you soon.

    #18434
    Mth
    Contributor

    Hello

    apologies for the late reply. I thought I had answered, but had left my message cached instead of posting on the day of you previous followup.

    So there are basically three problems there.
    First you seem to have run into a known bug with Xserver, when NoMachine queries for
    information before physical session is started, the Xserver will get confused and not let
    the physical session to be started. So the only solution is to keep the checkLocalSessionDelay
    key on default – removed or commented.

    Second, because of that problem, our session finding has to be delayed, and it is also a known problem, if someone tries to login before the session finding is complete, there will be a query sent to the player connecting to start new desktop. This is what happens in your logs. 5 seconds after NX
    startup, there is a connection with answer “yes” to creating new desktop. The proposition here
    is to answer “no” and wait for physical session to be detected.

    And this come to a third problem, which is black screen after selecting “yes”, this also should not happen.

    From the logs, what is started is ‘/etc/X11/Xsession default’ which exits after 6 seconds with no errors
    visible in our logs. This may be related with first problem, but we have not enough data to follow on this.
    Is there any problems in system logs during this time? There may also be something in .xsession-errors file in users home directory.

    /Mth

Viewing 7 posts - 1 through 7 (of 7 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.