Install error when updating 7.8.2 to 7.9.2_1

Forum / NoMachine for Windows / Install error when updating 7.8.2 to 7.9.2_1

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #38001

    Windows 10 64bit Pro

    Have NoMachine 7.8.2 installed and working, it says update available, I’ve tried saying install now, I’ve also tried downloading new installer from website. The new version installer starts, but says error that libnxdx64.dll is being used by another process. I can abort, retry or ignore, but it says ignore is discouraged.

    There was a notice that some nx things are running, click Next to close them, which I did.

    In Windows Task Manager, the nxservice is currently stopped. I cannot find any other app or process running that sounds (to me) related to nx.

    What else do I need to look for to End-Task on?



    We’re checking this. We encountered this same error a while back and have never been able to reproduce it again. Our library is being blocked by some Windows process. What you can do is click ignore, or reboot and then update NoMachine.  Alternatively, close the process that is locking the library.


    Just ran into this same issue.  Turns out Oracle VM VirtualBox was the culprit (at least for me this time).

    I didn’t see the file open in the resource manager, so I opted to manually browse to the install directory of NoMachine and manually rename the ‘libnxdx64.dll’, and in doing so the windows error message let it slip that it was in use by VirtualBox. Killed my running Linux VM and killed the Manager and the NoMachine installer continued without any issue.

    I’m now running 7.9.2_1


    Thanks for letting us know.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.