Installation fails: missing ssh keyfile

Forum / NoMachine for Linux / Installation fails: missing ssh keyfile

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #19516

    I had the free NoMachine working (with some issues) on a laptop running Linux Mint 18.3 “Sylvia,” Cinnamon desktop. The hard drive started to show errors. I replaced it with a larger SSD and reinstalled the same Linux Mint version on the clean drive. After installing some other applications I tried to install NoMachine, downloaded from the website. Installation seemed to proceed normally until the end, which showed:

    ERROR: Installation of NoMachine server is corrupted:
    ERROR: Missing /usr/NX/etc/keys/ ssh keyfile!
    ERROR: Please uninstall and reinstall the package again.

    Reinstalling didn’t change anything.

    Maybe I should back up, do a clean reinstall of Sylvia and try installing NoMachine before anything else. Or does NoMachine need something else before it’s installed?



    NoMachine doesn’t list Mint as a supported distro, so I did a sideways upgrade to Ubuntu 18.04.1 “Bionic Beaver” and immediately installed NoMachine. No problems, works both directions. Ubuntu does everything I need.


    Hello Marty39

    Looks like you have Mint 64 bits and you installed a package for 32 bits:

    1. Download the x64 package:

    2. Uninstall current package:

    sudo dpkg -P nomachine

    3. Remove all leftovers:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    4. Install new package:

    sudo dpkg -i nomachine_6.2.4_1_amd64.deb

    To check architecture of your machine you can use this command:

    uname -m

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.