Intermittent disconnects when screen is static

Forum / NoMachine for Linux / Intermittent disconnects when screen is static

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #36460

    I’m running NoMachine on a Manjaro server, viewing it on an ipad, and while it works great, it seems that if the screen contents are static for more than about 10 seconds, my nx connection repeatedly greys out and shows a ‘loading’ animation for a few seconds, before reconnecting again. It does this about every 10-30s, but the connection the whole time is in fact solid – if i’m forwarding music, it doesn’t skip, and if at any time i trigger something on the display to change (e.g by alt-tabbing, or scrolling up on the current page), it immediately updates and shows the connection as established again.

    While this is a relatively minor issue, it’s pretty distracting when I’m trying to read a page and every few seconds it goes to greyed out, then not, then greyed out, then not, over and over. Alternatively if i just constantly scroll a little up, then down, then up, then down, it doesn’t grey out, but that’s equally distracting!

    It’s hard to describe, but i couldn’t find anything similar to this on the forums. Any suggestions? I had a look for something akin to a ‘timeout interval’ or ‘heartbeat’, or ‘keepalive’ or something in the settings, but to no avail.



    do you have the possibility to try to connect from a different client (either Windows, Mac or Linux), just to narrow it down and make sure it is a problem only with the iPad?

    Please also tell us about your iPad model and iOS version.


    Hi fra81, thanks for the reply.

    That’s a good suggestion. I didn’t have access to another NoMachine client at the time, but I do now, so I gave it a try with the Linux desktop client – couldn’t reproduce the issue. One thing I didn’t mention – I connect to the ipad (an iPad 2 running iOS 8.4.1) over a USB cable using the tetherme app to provide USB networking. (The server runs on a Raspberry Pi 400 and I use the iPad as a display. Using USB networking means I don’t require an intermediate WiFi, as well as giving better performance). To test if the USB networking was causing the problem, I tried connecting the iPad over WiFi. Again, couldn’t reproduce the issue. So the USB networking is the problem? Tried it again with the USB this time. Again, couldn’t reproduce the issue….

    So, I’ve no idea what changed – no software updates or configuration changes happened before this issue appeared, and none have happened between then and now – but it seems the issue has gone as mysteriously as it came

    I guess there’s not much to do except close the issue…. until it reappears….

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as closed, you can't post.