Invalid module format trying to forward USB

Forum / NoMachine for Linux / Invalid module format trying to forward USB


Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #27647

    I have been unable to forward USB from my Windows to Linux and have read some posts on these forums. I saw this one:

    and so I ran the command on the linux server side: sudo insmod /usr/NX/bin/drivers/nxusb.ko and got this output:

    > insmod: ERROR: could not insert module /usr/NX/bin/drivers/nxusb.ko: Invalid module format

    and this in syslog:

    > May 19 10:47:27 jshellman kernel: [1214766.535604] nxusb: version magic ‘5.0.0-37-generic SMP mod_unload ‘ should be ‘5.3.0-51-generic SMP mod_unload ‘

    Is there a way to get past that?

    uname -a shows: Linux jshellman 5.3.0-51-generic #44~18.04.2-Ubuntu SMP Thu Apr 23 14:27:18 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux



    What version of the NoMachine application do you use?

    Looks like your nxusb.ko is compiled for 5.0.0-37-generic but your current kernel version is 5.3.0-51-generic, which means that you need to rebuild your nxusb.ko. Maybe you have updated your Linux kernel after NoMachine installation?

    First of all, install Linux headers for your current kernel as it’s described here:

    Further, you can manually compile your nxusb.ko as described in the same article, or just reinstall NoMachine.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.