IOS11 Beta, quote key(s) no longer work

Forum / NoMachine for Mobile / IOS11 Beta, quote key(s) no longer work


Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #15575

    Don’t know if anyone else has run into this, but I use NX a lot.  I’m running the public betas for iOS 11 on my iPad Pro and my iPhone and I’ve found that the quote key (single quote as well as double quote) stopped working, completely.  Whether using my Logitech BT keyboard OR the onscreen keyboard.  This makes doing a lot of things in Unix quite hard.  To say nothing of how my English typed looks when it all comes out as “Im, theyre, etc.”


    Hi. We can confirm the issue, thank you for reporting it. It is documented here:

    Single and double quotes no longer work after upgrading to iOS 11

    We’ll evaluate if we can release the fix as soon as possible, or include it in the next big release which is a couple of months away.


    Due to some new requirements to submit the App to Apple, we may have problems to update the version currently on the store, so releasing the fix in a very short time may not be an option. The next big release, requiring a few more weeks to be ready, is already aligned with new requirements and contains a complete overhaul of keyboard events implementation, so at the moment it is the most viable solution.


    Workaround in the meantime is to turn off Smart Punctuation in Settings / Keyboard.   I had the exact same issue, and this fixed it.

    I presume that support for Smart Punctuation will be worked into the iOS11 version of NoMachine.   Prompt – my preferred app for SSH – had the same issue, but just released a version that will support Smart Punctuation (i.e., translate the typographic quotes back to the basic stuff we need for UNIX terminal apps).


    Thanks for the tip. We’ve updated the TR.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.